aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Liske <thomas@fiasko-nw.net>2020-05-06 18:10:30 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-07 17:31:49 +0000
commitad9911e764d16a482113951939af43e7122baa87 (patch)
tree333703a7e7873a799dc32578c39e4a4ba082f9f3
parent17e0b0820f7b9414560fabd6111c408b31a32df5 (diff)
community/frr: upgrade to 7.3.1
-rw-r--r--community/frr/APKBUILD8
-rw-r--r--community/frr/json-c-0.14.patch32
2 files changed, 3 insertions, 37 deletions
diff --git a/community/frr/APKBUILD b/community/frr/APKBUILD
index 8d99b2c0ae8..0f162ca0c2d 100644
--- a/community/frr/APKBUILD
+++ b/community/frr/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Corbe <daniel@corbe.net>
pkgname=frr
-pkgver=7.3
-pkgrel=1
+pkgver=7.3.1
+pkgrel=0
pkgdesc="Free Range Routing is a fork of Quagga"
pkgusers="frr"
pkggroups="frr frrvty"
@@ -34,7 +34,6 @@ subpackages="$pkgname-dbg
$pkgname-snmp
"
source="https://github.com/FRRouting/frr/archive/frr-$pkgver.tar.gz
- json-c-0.14.patch
frr.initd
"
builddir="$srcdir"/$pkgname-$pkgname-$pkgver
@@ -125,6 +124,5 @@ snmp() {
mv "$pkgdir"/usr/lib/frr/libfrrsnmp.* "$subpkgdir/usr/lib/frr"
}
-sha512sums="7ac0049e2934105f5d8baedcce66117c7a946b3ffcba1dba7c9e332d8f10dbfd49e2758282c6487bec619f7610c122827f03fd1ef055896a130e8792478af9ef frr-7.3.tar.gz
-4124390c3756ce8a1dddc1753373b0ae668f0dc81e3a125758283b78a86a32e423f5a39d6cbe350ad8c84fac7079d12255e35cbbdd320f182c4d47e1444ee4a5 json-c-0.14.patch
+sha512sums="4b7e5ff1e4bf511ea7231024038eaafefd213088b5577b055f9886e118e1841a042aa541b4771338e6ebbb3a197cfddc91f361716e3c2d0a19f7f696117cba99 frr-7.3.1.tar.gz
b495b2be9f2cbb065104ccc0c3474471e870b53ac62ed4fba40020c8d50866e637a99ef3d7af5de1018ff659c4757baac4f40d7648a9de99ed14db33c8992b54 frr.initd"
diff --git a/community/frr/json-c-0.14.patch b/community/frr/json-c-0.14.patch
deleted file mode 100644
index 8e4860e6fe8..00000000000
--- a/community/frr/json-c-0.14.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff --git a/bgpd/bgp_route.c b/bgpd/bgp_route.c
-index 5f4486b..1e17d33 100644
---- a/bgpd/bgp_route.c
-+++ b/bgpd/bgp_route.c
-@@ -9922,7 +9922,7 @@ static int bgp_show_route_in_table(struct vty *vty, struct bgp *bgp,
- }
- } else if (safi == SAFI_EVPN) {
- struct bgp_node *longest_pfx;
-- bool is_exact_pfxlen_match = FALSE;
-+ bool is_exact_pfxlen_match = false;
-
- for (rn = bgp_table_top(rib); rn; rn = bgp_route_next(rn)) {
- if (prd && memcmp(rn->p.u.val, prd->val, 8) != 0)
-@@ -9932,7 +9932,7 @@ static int bgp_show_route_in_table(struct vty *vty, struct bgp *bgp,
- continue;
-
- longest_pfx = NULL;
-- is_exact_pfxlen_match = FALSE;
-+ is_exact_pfxlen_match = false;
- /*
- * Search through all the prefixes for a match. The
- * pfx's are enumerated in ascending order of pfxlens.
-@@ -9951,7 +9951,7 @@ static int bgp_show_route_in_table(struct vty *vty, struct bgp *bgp,
- int type5_pfxlen =
- bgp_evpn_get_type5_prefixlen(&rm->p);
- if (type5_pfxlen == match.prefixlen) {
-- is_exact_pfxlen_match = TRUE;
-+ is_exact_pfxlen_match = true;
- bgp_unlock_node(rm);
- break;
- }
-