aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-03-02 11:29:40 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-03 08:50:05 -0300
commitaf2d0b94ba612b3925c6cf3900d6cf89715f1a94 (patch)
tree7acfa1d222816f61639c5c2678392c849cdfd3eb
parent65868aded40cea35533890d8152dad05579066f6 (diff)
community/ktorrent: move from testing
-rw-r--r--community/ktorrent/APKBUILD (renamed from testing/ktorrent/APKBUILD)7
1 files changed, 4 insertions, 3 deletions
diff --git a/testing/ktorrent/APKBUILD b/community/ktorrent/APKBUILD
index ba467aa93df..5286b6d95b8 100644
--- a/testing/ktorrent/APKBUILD
+++ b/community/ktorrent/APKBUILD
@@ -20,20 +20,21 @@ subpackages="$pkgname-doc $pkgname-lang"
build() {
# The infowidget plugin is disabled due to an incompatibility with musl
- cmake \
+ cmake -B "$builddir"/build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DENABLE_INFOWIDGET_PLUGIN=FALSE
- make
+ make -C build
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
package() {
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" make -C build install
}
sha512sums="b62d05650216721299dc9db23da1a2d6ae5d3b77583ad4bd99ac032d7b135cce567feff3b66d27ac001d77e30517112e4e8c8bf8e83c1106a79509ec45498621 ktorrent-5.1.2.tar.xz"