aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-04-14 13:21:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-17 16:54:02 +0000
commitaf54e006e0571894778f1067475e6eb3fcce0387 (patch)
tree0ddc1f4de5a1aa812bf74df0c19606bec98b7118
parent5cc57a90bcc20e3a6daa2245110891434374aa8e (diff)
main/tmux: clarify license, improve abuild
-rw-r--r--main/tmux/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/main/tmux/APKBUILD b/main/tmux/APKBUILD
index 862012510e1..082d5b2f68f 100644
--- a/main/tmux/APKBUILD
+++ b/main/tmux/APKBUILD
@@ -4,16 +4,16 @@ pkgname=tmux
pkgver=2.7
pkgrel=0
pkgdesc="Tool to control multiple terminals from a single terminal"
-url="https://tmux.github.io/"
+url="https://tmux.github.io"
arch="all"
-license="BSD"
+license="BSD ISC"
depends="ncurses-terminfo"
-makedepends="ncurses-dev libevent-dev autoconf automake bsd-compat-headers"
+makedepends="autoconf automake bsd-compat-headers libevent-dev ncurses-dev"
install=
subpackages="$pkgname-doc"
source="https://github.com/tmux/tmux/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/"$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
@@ -36,9 +36,9 @@ package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
- install -Dm644 example_tmux.conf \
+ install -D -m644 example_tmux.conf \
"$pkgdir"/usr/share/doc/$pkgname/examples/$pkgname.conf
- for file in CHANGES README TODO; do
+ local file; for file in CHANGES README TODO; do
install -m644 "$file" "$pkgdir"/usr/share/doc/$pkgname/
done
}