aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-11-12 15:28:38 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-11-12 15:27:41 +0000
commitb251800d94f2c51c0732b98deb8a2adf8329038b (patch)
tree4b72bbc37f1d637c41ddfbc7e62426351d2afdbc
parent88c6af1659a53f2eb332e1ffee65c07d0906c599 (diff)
community/animatch: upgrade to 1.0.3
-rw-r--r--community/animatch/APKBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/community/animatch/APKBUILD b/community/animatch/APKBUILD
index f01b38f57df..2a667ef6b28 100644
--- a/community/animatch/APKBUILD
+++ b/community/animatch/APKBUILD
@@ -1,16 +1,21 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=animatch
-pkgver=1.0.2
+pkgver=1.0.3
pkgrel=0
-_commit_libsuperderpy="b592a3382fd5d3efc88a0df29031e267f6497910"
+_commit_libsuperderpy="d26adecc8eac53b5c9fa999fbd86c880418c01ed"
arch="all"
url="https://gitlab.com/HolyPangolin/animatch"
pkgdesc="Animatch is a match-three game with cute animals"
license="GPL-3.0-or-later"
-makedepends="cmake ninja allegro-dev mesa-dev"
+makedepends="
+ cmake
+ ninja
+ allegro-dev
+ mesa-dev"
source="https://gitlab.com/HolyPangolin/animatch/-/archive/v$pkgver/animatch-v$pkgver.tar.gz
- libsuperderpy-$_commit_libsuperderpy.tar.gz::https://gitlab.com/dosowisko.net/libsuperderpy/-/archive/$_commit_libsuperderpy.tar.gz"
+ libsuperderpy-$_commit_libsuperderpy.tar.gz::https://gitlab.com/dosowisko.net/libsuperderpy/-/archive/$_commit_libsuperderpy.tar.gz
+ "
subpackages="$pkgname-static $pkgname-doc"
options="!check" # No tests
builddir="$srcdir/$pkgname-v$pkgver"
@@ -20,7 +25,7 @@ prepare() {
# libsuperderpy doesn't have a stable ABI yet so build it statically to prevent conflicts with other packages using it
rmdir "$builddir"/libsuperderpy
- mv "$srcdir"/libsuperderpy-$_commit_libsuperderpy "$builddir"/libsuperderpy
+ mv "$srcdir/libsuperderpy-$_commit_libsuperderpy" "$builddir"/libsuperderpy
}
build() {
@@ -41,5 +46,5 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="6eb052e4aabf43032fb229757f65ed01739a3ecad2037e354d14dbeb0f5e1c88ec00054b9976b91309b0ddc7efcd684f2f97f50ddb7d15c740058a47015310df animatch-v1.0.2.tar.gz
-6fb917ebdd563f26475627ecd8f53d1fb59edb0a56965dff824178e41cbd53f8ea746289e491bddcd5cfbc091a047b4ca084af7a359e2aac4ae9c80093392071 libsuperderpy-b592a3382fd5d3efc88a0df29031e267f6497910.tar.gz"
+sha512sums="b44fddde0ba827f4233e81a12623872d8d258dc3d09a30749dd3033bd7114dc95ef9ab243f0d4f2125405853fbbdcf3abb58da010b4ce70ea2326c52abd7bc28 animatch-v1.0.3.tar.gz
+2cd142629a617d0a837640dc9aaaea99b14400b8dfabdd8837a56a3cdaaa88df2e0b57ee0b9073177c163c0d3770f6ae3613804c324066e0c40efeec255a0c24 libsuperderpy-d26adecc8eac53b5c9fa999fbd86c880418c01ed.tar.gz"