aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Berthault <justin.berthault@zaclys.net>2020-04-10 15:40:42 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-11 06:44:15 +0000
commitb2bc0d3e2115e5207ea460babdb180d1fef00df9 (patch)
treee763971edc9bc48d5970bcb8217a924d4674959d
parent0193331d53d6d63e804e9b80dbcc8bcf20aa2ab4 (diff)
testing/py3-pywal: new aport
https://github.com/dylanaraps/pywal/ Generate and change colorschemes on the fly testing/
-rw-r--r--testing/py3-pywal/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py3-pywal/APKBUILD b/testing/py3-pywal/APKBUILD
new file mode 100644
index 00000000000..5be1ebdbcba
--- /dev/null
+++ b/testing/py3-pywal/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Justin Berthault <justin.berthault@zaclys.net>
+# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
+pkgname=py3-pywal
+pkgver=3.3.0
+pkgrel=0
+pkgdesc="Generate and change colorschemes on the fly"
+url="https://github.com/dylanaraps/pywal/"
+arch="noarch"
+license="MIT"
+depends="
+ imagemagick
+ python3
+ py3-setuptools
+ "
+source="https://files.pythonhosted.org/packages/source/p/pywal/pywal-$pkgver.tar.gz"
+builddir="$srcdir/pywal-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="e8469ae1cb6596e78e9100907115e2075cfe6f984751e9972c36e60e27d1c379b4e8d2c5ef90becb689bcfcc1efb9702392e64602dbb93f903e12f3881ed42ce pywal-3.3.0.tar.gz"