aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-07-14 20:12:42 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2020-07-14 20:13:24 +0200
commitb3799e64fbe5cff874dcc1418960782489f9b6c2 (patch)
treeef9bb4752b0a9481836ee8e68d52cc21ec23eeb3
parent36fd1da7ea41f7dc92c14d0a3515b43d3d062700 (diff)
main/wpa_supplicant: add respawn-delay to wpa_cli service
Without this change wpa_cli fails to restart when restarting wpa_supplicant, i.e. after a configuration change. Briefly discussed on IRC with @Leo.
-rw-r--r--main/wpa_supplicant/APKBUILD4
-rw-r--r--main/wpa_supplicant/wpa_cli.initd9
2 files changed, 11 insertions, 2 deletions
diff --git a/main/wpa_supplicant/APKBUILD b/main/wpa_supplicant/APKBUILD
index c0aa32f3836..2b48b7773ca 100644
--- a/main/wpa_supplicant/APKBUILD
+++ b/main/wpa_supplicant/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wpa_supplicant
pkgver=2.9
-pkgrel=5
+pkgrel=6
pkgdesc="A utility providing key negotiation for WPA wireless networks"
url="https://w1.fi/wpa_supplicant/"
arch="all"
@@ -116,7 +116,7 @@ sha512sums="37a33f22cab9d27084fbef29856eaea0f692ff339c5b38bd32402dccf293cb849afd
2be5eca8be4c1c7bc70f718d4bc122488ffe08360496b5af91014366f2d1ef34e2ad9724b8b8c476209b47ededdfb807e2aa6a04a200ed827d4c8cfbee9e04a7 wpa_supplicant.initd
24bc4d46f3a8923890f233e433928c3f1204ab5f15a1c32b21dca220af89e2474026059e1040834db88cd3d8f6b61c46abb5cf18bda906e78dcd8fccd0f2a382 wpa_supplicant.confd
c3db077fa78dd296d90d07626cb4e684f87618a77ffd51c1ae04b47be7bc0db1e9a3e0f7442acef21c081f6bb782f150cbbd3d0bf245d6ab43f19da3899b53b9 wpa_cli.confd
-b63dcf28c5a4be36b8a3c08c93967122f9001f7fc825940aa78746666d000ccda3038e0226bd5771d37b3bbc8ad617d9ac9c766003173b052bf0d974188898ca wpa_cli.initd
+f4b9c86530a2b10cd50e6014c9bee1d143714ab9f86bf29119dcd2c86dec5239c356518a36147d6418e4eb31aa4a7df3e5c86647779d2b4626bffcfe6685f362 wpa_cli.initd
2be055dd1f7da5a3d8e79c2f2c0220ddd31df309452da18f290144d2112d6dbde0fc633bb2ad02c386a39d7785323acaf5f70e5969995a1e8303a094eb5fe232 eloop.patch
63710cfb0992f2c346a9807d8c97cbeaed032fa376a0e93a2e56f7742ce515e9c4dfadbdb1af03ba272281f639aab832f0178f67634c222a5d99e1d462aa9e38 CVE-2019-16275.patch
6707991f9a071f2fcb09d164d31d12b1f52b91fbb5574b70b8d6f9727f72bbe42b03dd66d10fcc2126f5b7e49ac785657dec90e88b4bf54a9aa5638582f6e505 config
diff --git a/main/wpa_supplicant/wpa_cli.initd b/main/wpa_supplicant/wpa_cli.initd
index f5a25a88966..2bf7c0d2c6a 100644
--- a/main/wpa_supplicant/wpa_cli.initd
+++ b/main/wpa_supplicant/wpa_cli.initd
@@ -2,6 +2,15 @@
supervisor=supervise-daemon
+# The wpa_cli services depends on wpa_supplicant. If wpa_supplicant is
+# restarted, so is wpa_cli. Unfortunately, wpa_supplicant creates the
+# socket, used for communication with wpa_cli, rather late thereby
+# causing wpa_cli to be restarted before it is created and thus fail.
+# By default supervise-daemon will restart wpa_cli immediately, often
+# resulting in all restart attempts to be exhausted before the socket is
+# created. To work around this issue, add a respawn-delay to wpa_cli.
+supervise_daemon_args="--respawn-delay 3"
+
name="WPA Command Line Client"
description="Text-based frontend for interacting with WPA Supplicant"