aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-13 13:52:56 -0300
committerShiz <hi@shiz.me>2017-05-14 03:32:57 +0200
commitb561ce3e3810bd9235907d7a4626d09789b6f249 (patch)
tree5d103eaa098f8340867da131555a8353c0ee169d
parentdaf5d66579a35c65a511e709bd8d5b912a22dc79 (diff)
community/xcalc: modernize abuild
-rw-r--r--community/xcalc/APKBUILD27
1 files changed, 6 insertions, 21 deletions
diff --git a/community/xcalc/APKBUILD b/community/xcalc/APKBUILD
index 2448c026a4a..4be3a509f3d 100644
--- a/community/xcalc/APKBUILD
+++ b/community/xcalc/APKBUILD
@@ -7,40 +7,25 @@ pkgdesc="Calculator for the X Window System"
url="http://www.x.org"
arch="all"
license="MIT"
-depends=""
-depends_dev=""
makedepends="libx11-dev libxaw-dev libxt-dev"
-install=""
subpackages="$pkgname-doc"
source="http://www.x.org/releases/individual/app/${pkgname}-${pkgver}.tar.bz2"
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --datarootdir=/usr/share \
- || return 1
- make || return 1
+ --datarootdir=/usr/share
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
-md5sums="397584a68bfe6b02adff16e67f8fe5dd xcalc-1.0.6.tar.bz2"
-sha256sums="2f73c7160c09dc32586ea07daa408ac897c0a16eaa98cad9f9e4ee98cd9057d8 xcalc-1.0.6.tar.bz2"
sha512sums="61b921b6a3fefea20bd9e7ad0b308f589f2aeaafe9316df94cc739a005be6c180bdafc981b8957230f46c9fc1c0e266829a55b473ae26b1377c705796175c908 xcalc-1.0.6.tar.bz2"