aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-05 22:09:12 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-05 22:39:40 +0100
commitb5b12cb83fab542d5dc16feaea669de6098b68bb (patch)
treeb27bb5a97cb55fc8766c6b3b20de072970462b5c
parent1f462fa249adeab8ad22f0182723ed6e639243f5 (diff)
testing/harminv: rebuild against lapack
-rw-r--r--testing/harminv/APKBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/testing/harminv/APKBUILD b/testing/harminv/APKBUILD
index 483de90617e..0fcd4443607 100644
--- a/testing/harminv/APKBUILD
+++ b/testing/harminv/APKBUILD
@@ -2,20 +2,18 @@
# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
pkgname=harminv
pkgver=1.4.1
-pkgrel=3
+pkgrel=4
pkgdesc="Free program to solve the problem of harmonic inversion"
url="https://github.com/stevengj/harminv"
arch="all"
license="GPL"
-depends_dev="openblas-dev>=0.3.0"
+depends_dev="openblas-dev>=0.3.0 lapack-dev"
makedepends="$depends_dev gfortran"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="$pkgname-$pkgver.tar.gz::https://github.com/stevengj/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
+source="harminv-$pkgver.tar.gz::https://github.com/stevengj/harminv/releases/download/v$pkgver/harminv-$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -30,12 +28,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}