aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-21 21:13:27 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-21 21:13:27 +0100
commitb6648267953fc96f422bf0fe42d190d59b982b5d (patch)
treeb3791b4a4fa9d3f2d57fc4b5cfae56a7bc470529
parentaa85ff073ab82466be469e0eefc20d9c5444670e (diff)
main/py3-filelock: rebuild against python3.8
-rw-r--r--main/py3-filelock/APKBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/main/py3-filelock/APKBUILD b/main/py3-filelock/APKBUILD
index a51668bcd93..fb1ed381445 100644
--- a/main/py3-filelock/APKBUILD
+++ b/main/py3-filelock/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-filelock
_pkgname=filelock
pkgver=3.0.12
-pkgrel=1
+pkgrel=2
pkgdesc="A platform independent file lock for Python3"
url="https://github.com/benediktschmitt/py-filelock"
arch="noarch"
@@ -18,17 +18,14 @@ replaces="py-filelock" # Backwards compatibility
provides="py-filelock=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 -m pytest -xvv test.py
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}