aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2019-05-15 13:17:48 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-06 21:50:08 -0300
commitb8bc2d7d341ab0eabd802c2472872db310540cf3 (patch)
tree706db22a7f6b438bafb294b8bfd6108d4c284dd9
parent4d2ffc7d3f447f2bcd6bddf2c04285f1c502c98b (diff)
testing/asciinema-rs: new aport
-rw-r--r--testing/asciinema-rs/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/asciinema-rs/APKBUILD b/testing/asciinema-rs/APKBUILD
new file mode 100644
index 00000000000..0c806f73120
--- /dev/null
+++ b/testing/asciinema-rs/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=asciinema-rs
+pkgver=0.5.1
+pkgrel=0
+pkgdesc="A reimplementation of the asciinema command line program written in Rust."
+url="https://github.com/LegNeato/asciinema-rs"
+arch="x86_64" # Limited by cargo
+license="Apache-2.0 MIT"
+provides="asciinema"
+makedepends="cargo openssl-dev"
+source="https://github.com/LegNeato/asciinema-rs/archive/v$pkgver/$pkgname-v$pkgver.tar.gz"
+
+build() {
+ cargo build --release --locked
+}
+
+check() {
+ cargo test --release --locked
+}
+
+package() {
+ install -Dt "$pkgdir"/usr/bin target/release/asciinema
+}
+
+sha512sums="59a786a6a82122c33200bc7eb30e96e38548e45eb478eae259fa8ccd601b0bd596d4d9066ce75a5dc95abdaa97554f4a05cc2218b4c228566a65ed510d35c600 asciinema-rs-v0.5.1.tar.gz"