aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2021-05-31 23:43:58 +0200
committerBart Ribbers <bribbers@disroot.org>2021-05-31 22:13:07 +0000
commitb8c28f7d50dd39bbe8b46935fa06c4e3e45ea319 (patch)
treeaa60bed5f6c658796ca0b97294dcb7e49d2b84e8
parent087a2429a84d3502ee6fe3e5d4e517c03fcb32ee (diff)
community/fluidsynth: upgrade to 2.2.1
-rw-r--r--community/fluidsynth/APKBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/community/fluidsynth/APKBUILD b/community/fluidsynth/APKBUILD
index d528707868f..89aabd730f4 100644
--- a/community/fluidsynth/APKBUILD
+++ b/community/fluidsynth/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=fluidsynth
-pkgver=2.2.0
-pkgrel=1
+pkgver=2.2.1
+pkgrel=0
arch="all"
url="https://www.fluidsynth.org/"
pkgdesc="A real-time software synthesizer based on the SoundFont 2 specifications"
@@ -24,6 +24,11 @@ makedepends="$depends_dev
source="https://github.com/fluidsynth/fluidsynth/archive/v$pkgver/fluidsynth-v$pkgver.tar.gz"
subpackages="$pkgname-dev $pkgname-doc"
+# tests are broken on s390x
+case "$CARCH" in
+ s390x) options="!check"
+esac
+
build() {
cmake -B build \
-DCMAKE_BUILD_TYPE=None \
@@ -34,12 +39,15 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ # ctest can't currently be used https://github.com/FluidSynth/fluidsynth/issues/881
+
+ make -C build check
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="fa08c6d6914accbb5a99bb912066d97ded26ab3c706e663e76a4f1b024f610f676d2e1f7c30872d00e0fe86b5c494dcea581ecd0770977d235962a845c074bd6 fluidsynth-v2.2.0.tar.gz"
+sha512sums="
+a42728f179fd2583a292d18d9b7d98498b42574aff6559e8e3762329893dd18c451b5611517aa9aa7ee6ba9fc0db3c83e127d097c68769c5d8562a49dc427ee9 fluidsynth-v2.2.1.tar.gz
+"