aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-10-14 14:20:43 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-10-15 19:14:33 -0300
commitb98fa02ec77e7aeccc4e429cb439acbeb407ecff (patch)
tree525fede03179745391650c679c7ef7b7c04274ab
parent74b4b586720b58bc185c2168c63eb2f467870025 (diff)
community/py3-pygit2: rebuild against libgit2.so.1.1
-rw-r--r--community/py3-pygit2/APKBUILD11
-rw-r--r--community/py3-pygit2/libgit-110.patch34
2 files changed, 41 insertions, 4 deletions
diff --git a/community/py3-pygit2/APKBUILD b/community/py3-pygit2/APKBUILD
index 24a590d4a41..5ffbd5e3c19 100644
--- a/community/py3-pygit2/APKBUILD
+++ b/community/py3-pygit2/APKBUILD
@@ -4,16 +4,18 @@
pkgname=py3-pygit2
_pkgname=pygit2
pkgver=1.3.0
-pkgrel=0
+pkgrel=1
pkgdesc="Python bindings for libgit2"
url="https://github.com/libgit2/pygit2"
arch="all"
license="GPL-2.0 WITH GCC-exception-2.0"
depends="py3-cffi py3-cached-property"
makedepends="python3-dev py3-setuptools libgit2-dev"
-checkdepends="py3-pytest py3-hypothesis py3-cached-property"
+checkdepends="py3-pytest py3-hypothesis"
source="https://pypi.io/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz
- s390x-patch-context-mark-xfail.patch"
+ s390x-patch-context-mark-xfail.patch
+ libgit-110.patch
+ "
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-pygit" # Backward compat
@@ -32,4 +34,5 @@ package() {
}
sha512sums="297c6aef27019ca540d7ec9c26da7a5e870a7e5c2e06daa1a038023c4ab32c800b2494970e41a3d576e17e1d2c33402c3116389d9e2ebe1c2def0ba529dbde71 pygit2-1.3.0.tar.gz
-c0e22ae9a50cb727bae87fd2b03c5b71b7aee77b88764133b9d60d78a9903895d80db10c037859cbc9bfc06d251c2ed169b63c06798e70169de2b39b12fa0fc5 s390x-patch-context-mark-xfail.patch"
+c0e22ae9a50cb727bae87fd2b03c5b71b7aee77b88764133b9d60d78a9903895d80db10c037859cbc9bfc06d251c2ed169b63c06798e70169de2b39b12fa0fc5 s390x-patch-context-mark-xfail.patch
+4feb4274e1459400bfc3bdde3e667cadbbbd9425f084704447a679663665e9c145316443c76e64a1b6eb0b837a5d8e627f232dc511af69909edf612c4e61ac31 libgit-110.patch"
diff --git a/community/py3-pygit2/libgit-110.patch b/community/py3-pygit2/libgit-110.patch
new file mode 100644
index 00000000000..6825f1c062d
--- /dev/null
+++ b/community/py3-pygit2/libgit-110.patch
@@ -0,0 +1,34 @@
+From b57aa0e889fe07d7b4663d0729a40f4a9ecf5578 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?J=2E=20David=20Ib=C3=A1=C3=B1ez?= <jdavid.ibp@gmail.com>
+Date: Wed, 14 Oct 2020 08:36:08 +0200
+Subject: [PATCH] Upgrade to libgit2 1.1
+
+Fixes #1040
+
+diff --git a/src/pygit2.c b/src/pygit2.c
+index 4e144705..0693a790 100644
+--- a/src/pygit2.c
++++ b/src/pygit2.c
+@@ -590,6 +590,7 @@ PyInit__pygit2(void)
+ ADD_CONSTANT_INT(m, GIT_BLAME_TRACK_COPIES_ANY_COMMIT_COPIES)
+ ADD_CONSTANT_INT(m, GIT_BLAME_FIRST_PARENT)
+ ADD_CONSTANT_INT(m, GIT_BLAME_USE_MAILMAP)
++ ADD_CONSTANT_INT(m, GIT_BLAME_IGNORE_WHITESPACE)
+
+ /* Merge */
+ ADD_CONSTANT_INT(m, GIT_MERGE_ANALYSIS_NONE)
+diff --git a/src/types.h b/src/types.h
+index 0f3c8cf9..8ea01d38 100644
+--- a/src/types.h
++++ b/src/types.h
+@@ -32,8 +32,8 @@
+ #include <Python.h>
+ #include <git2.h>
+
+-#if !(LIBGIT2_VER_MAJOR == 1 && LIBGIT2_VER_MINOR == 0)
+-#error You need a compatible libgit2 version (1.0.x)
++#if !(LIBGIT2_VER_MAJOR == 1 && LIBGIT2_VER_MINOR == 1)
++#error You need a compatible libgit2 version (1.1.x)
+ #endif
+
+ /*