aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2020-10-02 07:03:52 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2020-10-02 07:03:52 +0000
commitb9ec454379e811024f18c4861efffa51a694c236 (patch)
tree2fec908003792bda42a769e7188c81dd1a1e1d03
parent9b07c69ca2e2bbc9a3a226f7d0ea46d1dd6ad470 (diff)
community/xcursorgen: new aport
Needed by capitaine-cursors r4
-rw-r--r--community/xcursorgen/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/xcursorgen/APKBUILD b/community/xcursorgen/APKBUILD
new file mode 100644
index 00000000000..e6dea80bbbe
--- /dev/null
+++ b/community/xcursorgen/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=xcursorgen
+pkgver=1.0.7
+pkgrel=0
+pkgdesc="Create and X cursor file from PNG images"
+url="https://xorg.freedesktop.org/archive/individual/app/"
+arch="all"
+license="Custom"
+makedepends="xorg-server-dev libxcursor-dev libpng-dev"
+subpackages="$pkgname-doc"
+source="https://xorg.freedesktop.org/archive/individual/app/xcursorgen-$pkgver.tar.bz2"
+
+build() {
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
+
+check() {
+ make check
+}
+
+sha512sums="bd13ad23691d3daa2d5dcdc5902cf62e3dcb97a0289aff362e6cd85866a1d8cafb64f98800a75bfb4cf1f3c76244ca20201847dff594543d136d0abaec7011d2 xcursorgen-1.0.7.tar.bz2"