aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoni Aloy Torrens <aaloytorrens@gmail.com>2021-02-12 02:19:21 +0100
committerLeo <thinkabit.ukim@gmail.com>2021-03-21 07:10:37 +0000
commitba24b4b2983f513a7b6089fa0b7e9193edadc3dc (patch)
tree46d8d42b1f82b0a6cee985c4947b3b5a06184744
parentf8eec9d5f9fd202c66d9908391ca3cb105555a76 (diff)
testing/lxqt-sudo: new aport
-rw-r--r--testing/lxqt-sudo/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/lxqt-sudo/APKBUILD b/testing/lxqt-sudo/APKBUILD
new file mode 100644
index 00000000000..7300a7c5122
--- /dev/null
+++ b/testing/lxqt-sudo/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
+pkgname=lxqt-sudo
+pkgver=0.16.0
+pkgrel=0
+pkgdesc="Tools to sudoure LXQt and the underlying operating system"
+url="https://github.com/lxqt/lxqt-sudo"
+arch="all"
+license="LGPL-2.0-or-later"
+makedepends="
+ cmake libxcursor-dev lxqt-build-tools qt5-qtbase-dev
+ qt5-qttools-dev qt5-qtx11extras-dev xf86-input-libinput-dev
+ libxi-dev libudev-zero-dev libqtxdg-dev liblxqt-dev
+ libkscreen-dev kwindowsystem-dev
+ "
+subpackages="$pkgname-doc"
+options="!check" # No testsuite
+source="https://github.com/lxqt/lxqt-sudo/releases/download/$pkgver/lxqt-sudo-$pkgver.tar.xz"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ $CMAKE_CROSSOPTS .
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --build build --target install
+}
+sha512sums="425c1bf1a4c2a6fe3933419c77e0d1c5f576902cf5cfd2550890e037c32c3021eb8294831f26690ff2488ed096fcd271d664d9f67e73374559c53e7669089694 lxqt-sudo-0.16.0.tar.xz"