aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAriadne Conill <ariadne@dereferenced.org>2021-05-03 18:11:09 -0600
committerAriadne Conill <ariadne@dereferenced.org>2021-05-03 18:11:09 -0600
commitbd9fc3cc64fcceb45ea3f55f442100ec0586dc61 (patch)
treef3d7afbd9f88f8fbc83d3e04f8a6db3487f99cbf
parent19eb1484e00c4d61e673c88afc4d7c8e0acfca80 (diff)
main/busybox: switch to libretls from libtls-standalone
-rw-r--r--main/busybox/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index 985ba710513..46745ca4bd4 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -4,13 +4,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.33.1
-pkgrel=0
+pkgrel=1
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url="https://busybox.net/"
arch="all"
license="GPL-2.0-only"
makedepends_build="perl"
-makedepends_host="linux-headers openssl-dev libtls-standalone-dev"
+makedepends_host="linux-headers openssl-dev libretls-dev"
makedepends="$makedepends_build $makedepends_host"
checkdepends="zip"
provides="/bin/sh"
@@ -83,8 +83,8 @@ build() {
msg "Building ssl_client"
# shellcheck disable=SC2046 # Allow wordsplitting for pkg-config
- ${CC:-${CROSS_COMPILE}gcc} ${CPPFLAGS} ${CFLAGS} $(pkg-config --cflags libtls-standalone) \
- "$srcdir"/ssl_client.c -o "$_dyndir"/ssl_client ${LDFLAGS} $(pkg-config --libs libtls-standalone)
+ ${CC:-${CROSS_COMPILE}gcc} ${CPPFLAGS} ${CFLAGS} $(pkg-config --cflags libtls) \
+ "$srcdir"/ssl_client.c -o "$_dyndir"/ssl_client ${LDFLAGS} $(pkg-config --libs libtls)
# no timestamp in build
export KCONFIG_NOTIMESTAMP=1