aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-15 12:44:03 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-15 12:56:58 +0000
commitbe1b98412800f8063bee24a2856e93b1e3ee9619 (patch)
tree7e2fe121ca54414c6393d55482a555f5d5d701f8
parentc9445ec78f387072ddaef2baec606d48c60a60e0 (diff)
community/arping: fix check
Change check to use a simple test instead of `make check`. Seems `make check` requires root to run correctly. Anyway, I opened a bug upstream related with tests failing on Alpine [1]. [1] - https://github.com/ThomasHabets/arping/issues/27
-rw-r--r--community/arping/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/arping/APKBUILD b/community/arping/APKBUILD
index 96dd410cd4f..d464c7cab76 100644
--- a/community/arping/APKBUILD
+++ b/community/arping/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=arping
pkgver=2.19
-pkgrel=0
+pkgrel=1
pkgdesc="An ARP ping utility"
url="http://www.habets.pp.se/synscan/programs.php?prog=arping"
arch="all"
@@ -16,7 +16,7 @@ builddir="$srcdir"/$pkgname-$pkgver
check() {
cd "$builddir"
- make check
+ ./src/arping --help > /dev/null
}
build() {