aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-04 21:16:31 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-05 18:07:02 +0000
commitbeea208828b3f8bdc1927f3481964ccccb596aa0 (patch)
tree09fbabf4342ba60e115d562963add542254ecb5a
parent5b9fa3fb45bcc423e9c345d0b98f4b353e8d6af7 (diff)
community/bspwm: Correct comment on why check is disabled and modernize
-rw-r--r--community/bspwm/APKBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/community/bspwm/APKBUILD b/community/bspwm/APKBUILD
index d2e4037c694..7a07b07cd3f 100644
--- a/community/bspwm/APKBUILD
+++ b/community/bspwm/APKBUILD
@@ -8,22 +8,19 @@ url="https://github.com/baskerville/bspwm"
arch="all"
license="BSD-2-Clause"
makedepends="libxcb-dev xcb-util-dev xcb-util-wm-dev xcb-util-keysyms-dev"
-options="!check" # depends on missing jshon package
+options="!check" # Requires connecting to bspwm socket
subpackages="
$pkgname-doc
$pkgname-zsh-completion:zshcomp:noarch
$pkgname-bash-completion:bashcomp:noarch
$pkgname-fish-completion:fishcomp:noarch"
source="$pkgname-$pkgver.tar.gz::https://github.com/baskerville/bspwm/archive/$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
make PREFIX=/usr
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" PREFIX=/usr install
}
@@ -49,8 +46,8 @@ bashcomp() {
}
fishcomp() {
- pkgdesc="Fish completion for $pkgname"
depends=""
+ pkgdesc="Fish completion for $pkgname"
install_if="$pkgname=$pkgver-r$pkgrel fish"
mkdir -p "$subpkgdir"/usr/share/fish/completions/