aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-09-01 00:23:45 +0200
committerMilan P. Stanić <mps@arvanta.net>2021-01-07 12:11:47 +0000
commitc3346eb064390063e1e717d898bba857abba2bee (patch)
treef16e81c35a5fec5eefa5e28a5d4ee507ef71bb00
parent15f905749e5180fc323848b610bd02e0ca0ac4bb (diff)
testing/xastir: new aport
http://xastir.org radio amateur mapping, tracking, messaging, weather, and search & rescue
-rw-r--r--testing/xastir/APKBUILD38
-rw-r--r--testing/xastir/fix-mutex.patch15
2 files changed, 53 insertions, 0 deletions
diff --git a/testing/xastir/APKBUILD b/testing/xastir/APKBUILD
new file mode 100644
index 00000000000..e2c3513abd1
--- /dev/null
+++ b/testing/xastir/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname=xastir
+pkgver=2.1.6
+pkgrel=0
+pkgdesc="radio amateur mapping, tracking, messaging, weather, and Search & Rescue"
+url="https://xastir.org"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="linux-headers libxrender-dev libxt-dev libxp-dev curl-dev pcre-dev motif-dev libax25-dev autoconf automake"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Xastir/Xastir/archive/Release-$pkgver.tar.gz
+ fix-mutex.patch
+ "
+builddir="$srcdir"/Xastir-Release-$pkgver
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="91f40f3788f51589619833102d1db997ff725f84e6fa5f9b7dd8942094a1b7a94433779243be1c14b980d96613972482a397cec8e15b8ea4784fdd106c32ae08 xastir-2.1.6.tar.gz
+2ed800774f2cdbbe1e096e967a896f4e31ba53d5c7ca2c770c74c6ba56967b69a1b56ca940fdcc618853b62284532741ffe3051824deb1be6a98773693508d0c fix-mutex.patch"
diff --git a/testing/xastir/fix-mutex.patch b/testing/xastir/fix-mutex.patch
new file mode 100644
index 00000000000..129cd38b4d1
--- /dev/null
+++ b/testing/xastir/fix-mutex.patch
@@ -0,0 +1,15 @@
+--- a/src/util.c 2019-07-15 00:30:31.000000000 +0200
++++ b/src/util.c 2019-08-31 15:56:13.580212122 +0200
+@@ -5457,10 +5457,10 @@
+ // NON_LSB VERSION
+ // Check first for newer pthread function
+ # ifdef HAVE_PTHREAD_MUTEXATTR_SETTYPE
+- (void)pthread_mutexattr_settype(&attr, PTHREAD_MUTEX_ERRORCHECK_NP);
++ (void)pthread_mutexattr_settype(&attr, PTHREAD_MUTEX_ERRORCHECK);
+ # else
+ // Use older, deprecated pthread function
+- (void)pthread_mutexattr_setkind_np(&attr, PTHREAD_MUTEX_ERRORCHECK_NP);
++ (void)pthread_mutexattr_setkind_np(&attr, PTHREAD_MUTEX_ERRORCHECK);
+ # endif // HAVE_PTHREAD_MUTEXATTR_SETTYPE
+ # endif // __LSB__
+