aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-09-12 10:00:50 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-09-12 08:17:50 +0000
commitc4963c42322ee441711fb298e0d97c7f92d2e230 (patch)
treee1cd330197b7e2f72374110083fd9c6ced9e6960
parent2f4d1d77a538834b5d2d1440558bdc20e262eb44 (diff)
community/gdm: upgrade to 3.38.0
-rw-r--r--community/gdm/APKBUILD6
-rw-r--r--community/gdm/remove-systemd-dep.patch25
2 files changed, 23 insertions, 8 deletions
diff --git a/community/gdm/APKBUILD b/community/gdm/APKBUILD
index 0a55541e4ab..daccb2e2370 100644
--- a/community/gdm/APKBUILD
+++ b/community/gdm/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gdm
-pkgver=3.37.90
+pkgver=3.38.0
pkgrel=0
pkgdesc="GNOME display manager"
url="https://wiki.gnome.org/Projects/GDM"
@@ -43,8 +43,8 @@ package() {
install -m755 -D "$srcdir/Xsession" "$pkgdir"/etc/gdm
install -m755 -D "$srcdir/$pkgname.initd" "$pkgdir"/etc/init.d/gdm
}
-sha512sums="c0ca18ab9842ea2f2a6e876a25bc305bf0100dc259d22a27424a0bb5496a05113746369fc224bf514e0ae69352e231757c810c12c723546518a165ce4d31591b gdm-3.37.90.tar.xz
+sha512sums="575185918975ebfb117bdb8f6f1847c18ca08333bbb42dc575035cb587588331670c7123349b62324a4a868d227723e556176c66fc89a5391aebc786d49f97e7 gdm-3.38.0.tar.xz
84eaadf000984d547426e853ce2dc380314c707d8aae926fb127f68b6c6af886b0aec05db9ae21a394f94beb81924b00424f082a606d97bde5edfced840fe4fa 0004-pam-arch-Update-to-match-pambase-20200721.1-2.patch
-a48ef7505034e0e0fbadf9bb980ae95c4a0562c29f67d1c5007f7371f707aad27621330dadf1922bbcd4aa6c6c3536e2f27abdf0e99055a446197bb10910e5ef remove-systemd-dep.patch
+695d3c0c56d10baabb24b9e43bc14ab44542cb44a5aed15d471d06eecdfe1313678c854a640a151de239b4a30071dc781cc616296a2785ca43512a31403cdb3c remove-systemd-dep.patch
cd4c8f80e37dc362727bd535cbe1d3917f2bc47d52af717595e19709051ab5f27c0f650195152ccd1a7e5e2f886e4e8bc60287f05dcd81e84237c7f78c89223f gdm.initd
f836cf0acdf148f2ae09ac28251b5126ce597f08254c43b1ec77596f75e1a3229926116c13f98554625be763e8d28415b27bd679b0a5de9f86bdca7857054c82 Xsession"
diff --git a/community/gdm/remove-systemd-dep.patch b/community/gdm/remove-systemd-dep.patch
index c6b5d257a17..d2f71bcd5b2 100644
--- a/community/gdm/remove-systemd-dep.patch
+++ b/community/gdm/remove-systemd-dep.patch
@@ -1,11 +1,26 @@
The systemd dep is only required for determining the systemd{user,system}unitddir
---- a/meson.build.orig 2020-08-31 12:07:34.734015573 +0200
-+++ b/meson.build 2020-08-31 12:07:42.170625714 +0200
-@@ -93,7 +93,6 @@
+diff --git a/meson.build b/meson.build
+index 7e336bf..8edc27c 100644
+--- a/meson.build
++++ b/meson.build
+@@ -94,19 +94,8 @@ if xdmcp_dep.found() and get_option('tcp-wrappers')
libwrap_dep = cc.find_library('libwrap')
endif
# systemd
-systemd_dep = dependency('systemd')
libsystemd_dep = dependency('libsystemd')
- journald_dep = dependency('journald', required: get_option('systemd-journal'))
- systemd_multiseat_x = find_program('systemd-multi-seat-x', required: false)
+-if meson.version().version_compare('>= 0.53')
+- systemd_multiseat_x = find_program('systemd-multi-seat-x',
+- required: false,
+- dirs: [
+- systemd_dep.get_pkgconfig_variable('systemdutildir'),
+- '/lib/systemd',
+- '/usr/lib/systemd',
+- ])
+-else
+- systemd_multiseat_x = find_program('systemd-multi-seat-x', required: false)
+-endif
++systemd_multiseat_x = find_program('systemd-multi-seat-x', required: false)
+ systemd_x_server = systemd_multiseat_x.found()? systemd_multiseat_x.path() : '/lib/systemd/systemd-multi-seat-x'
+ # Plymouth
+ plymouth_dep = dependency('ply-boot-client', required: get_option('plymouth'))