aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2020-03-07 15:11:38 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-03-10 14:44:24 -0300
commitc5cf5b9c49e25e4d71f83fe1f70609dee38f64c3 (patch)
tree48fabb5883d4c4a24f4208fd4077b77f8f3a8818
parent4b0f393e9ffe0c0c2a7ccd16cf14f8ee88cf3337 (diff)
main/perl-astro-suntime: adapt to perl-time-parsedate rename
-rw-r--r--main/perl-astro-suntime/APKBUILD31
1 files changed, 16 insertions, 15 deletions
diff --git a/main/perl-astro-suntime/APKBUILD b/main/perl-astro-suntime/APKBUILD
index d8069a78f0a..a7c37121e38 100644
--- a/main/perl-astro-suntime/APKBUILD
+++ b/main/perl-astro-suntime/APKBUILD
@@ -1,32 +1,33 @@
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Francesco Colista <francesco.colista@gmail.com>
# Maintainer: Francesco Colista <francesco.colista@gmail.com>
pkgname=perl-astro-suntime
-_realname=Astro-SunTime
+_pkgreal=Astro-SunTime
pkgver=0.06
-pkgrel=1
-pkgdesc="Provides a function interface to calculate sun rise/set times."
-url="https://metacpan.org/release/Astro-SunTime"
+pkgrel=2
+pkgdesc="A functional module for calculating sunrise/sunset times"
+url="https://metacpan.org/release/Astro-SunTime/"
arch="noarch"
-license="GPL-1.0-or-later OR Artistic-1.0-Perl"
-depends="perl"
-makedepends="perl-dev perl-time-modules"
+license="GPL-3.0-only"
+depends="perl perl-time-parsedate"
+makedepends="perl-dev perl-module-build"
+checkdepends="perl-time-parsedate"
source="https://cpan.metacpan.org/authors/id/R/RO/ROBF/Astro-SunTime-$pkgver.tar.gz"
-
-builddir="$srcdir/$_realname-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ perl Build.PL --installdirs=vendor
+ ./Build
}
check() {
- make test
+ ./Build test
}
package() {
- make DESTDIR="$pkgdir" install
- # creates file collision among perl modules
- find "$pkgdir" -name perllocal.pod -delete
+ ./Build install destdir="$pkgdir"
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
sha512sums="58efedf8aa401ac9d4dbd526e19d67429b9740588e8706f7d5320c35b20e98014c5978ef9d76eacbfa551f5c323a74ad106331748a6ad77c537c0750da8ae65e Astro-SunTime-0.06.tar.gz"