aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-07-03 17:27:55 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-07-11 06:57:57 +0000
commitc60d651f30982c74cb0ed3bbc6085ce68b7fa251 (patch)
tree2c3029dc663ea16fdc9973a71e540239467354b6
parent04f8d6108495165a9416a750f1440b324a95d33c (diff)
testing/mycroft-skill-speedtest: new aport
-rw-r--r--testing/mycroft-skill-speedtest/APKBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/testing/mycroft-skill-speedtest/APKBUILD b/testing/mycroft-skill-speedtest/APKBUILD
new file mode 100644
index 00000000000..6d4adf846ca
--- /dev/null
+++ b/testing/mycroft-skill-speedtest/APKBUILD
@@ -0,0 +1,20 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=mycroft-skill-speedtest
+pkgver=1.0
+pkgrel=0
+pkgdesc="Ask Mycroft to run a simple speedtest"
+url="https://github.com/luke5sky/speedtest-skill"
+arch="noarch"
+license="Apache-2.0"
+depends="python3"
+source="https://github.com/luke5sky/speedtest-skill/archive/$pkgver/speedtest-skill-$pkgver.tar.gz"
+options="!check" # No tests
+builddir="$srcdir/speedtest-skill-$pkgver"
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/mycroft/skills/speedtest
+ cp -r ./* "$pkgdir"/usr/share/mycroft/skills/speedtest/
+}
+
+sha512sums="2fbefc031996d52ea62a3d18460b440117170cdb715d258dfb5ddf64d3af801c4b4edf9cc2e02c243b5514ee5a4e9313d4387e8201237c262d95c304af76c081 speedtest-skill-1.0.tar.gz"