aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-11-02 10:01:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-11-02 10:02:38 +0000
commitc694f448a5d423a5d26d96350731bb594d107dbe (patch)
treeb5e62a160e2db3d30611f2b67259a42d17052af8
parenta1103ca3b847242fa78f89ff86c49d39d9cc564d (diff)
main/lxc-templates-legacy: add support for mips64 and s390x
-rw-r--r--main/lxc-templates-legacy/APKBUILD9
-rw-r--r--main/lxc-templates-legacy/add-mips64-s390x.patch15
2 files changed, 21 insertions, 3 deletions
diff --git a/main/lxc-templates-legacy/APKBUILD b/main/lxc-templates-legacy/APKBUILD
index d7752f099fc..67f349fb0c3 100644
--- a/main/lxc-templates-legacy/APKBUILD
+++ b/main/lxc-templates-legacy/APKBUILD
@@ -2,14 +2,16 @@
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=lxc-templates-legacy
pkgver=3.0.3
-pkgrel=0
+pkgrel=1
pkgdesc="Legacy LXC container templates"
url="https://linuxcontainers.org"
arch="noarch"
license="LGPL-2.1"
depends="bash tar"
subpackages="$pkgname-alpine"
-source="https://linuxcontainers.org/downloads/lxc/lxc-templates-$pkgver.tar.gz"
+source="https://linuxcontainers.org/downloads/lxc/lxc-templates-$pkgver.tar.gz
+ add-mips64-s390x.patch
+ "
builddir="$srcdir/lxc-templates-$pkgver"
build() {
@@ -45,4 +47,5 @@ alpine() {
done
}
-sha512sums="3e9d5304f5e06580eeb766570ddfebb0c80061c2d7e47c9ea37d834fe0cf4fabe7eedd667e4937df3f2451bc3e7aa1e98a1b386f3b19964dc218ff0e21011632 lxc-templates-3.0.3.tar.gz"
+sha512sums="3e9d5304f5e06580eeb766570ddfebb0c80061c2d7e47c9ea37d834fe0cf4fabe7eedd667e4937df3f2451bc3e7aa1e98a1b386f3b19964dc218ff0e21011632 lxc-templates-3.0.3.tar.gz
+e450bbf3219971955dbc6ac4388d7fea84288a55214ed47dcca93df31eb0ce119321072c5d01423709e3437e2148096947a05c2f4afa28ff8eb1277ebf40646a add-mips64-s390x.patch"
diff --git a/main/lxc-templates-legacy/add-mips64-s390x.patch b/main/lxc-templates-legacy/add-mips64-s390x.patch
new file mode 100644
index 00000000000..244bdb2d20e
--- /dev/null
+++ b/main/lxc-templates-legacy/add-mips64-s390x.patch
@@ -0,0 +1,15 @@
+diff --git a/templates/lxc-alpine.in b/templates/lxc-alpine.in
+index 543961c..932ef4f 100644
+--- a/templates/lxc-alpine.in
++++ b/templates/lxc-alpine.in
+@@ -127,9 +127,8 @@ parse_arch() {
+ x86 | i[3-6]86) echo 'x86';;
+ x86_64 | amd64) echo 'x86_64';;
+ aarch64 | arm64) echo 'aarch64';;
+- armv7) echo 'armv7';;
+ arm*) echo 'armhf';;
+- ppc64le) echo 'ppc64le';;
++ armv7 | mips64 | ppc64le | s390x) echo "$1";;
+ *) return 1;;
+ esac
+ }