aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2020-06-12 10:13:39 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2020-06-12 10:15:03 +0000
commitc784cc715c224b243e05f3e23ca2fb5c198625dd (patch)
tree90462e39a7252cf88dcee4fc313f4f612caa3550
parent311e0835f9e15d773889a8a60d4380716919bc63 (diff)
community/nextcloud: upgrade to 19.0.0
-rw-r--r--community/nextcloud/APKBUILD30
-rw-r--r--community/nextcloud/iconv-ascii-translit-not-supported.patch12
-rw-r--r--community/nextcloud/nextcloud17-app-encryption-info-add-mcrypt.patch2
-rw-r--r--community/nextcloud/nextcloud19-dont-chmod.patch (renamed from community/nextcloud/nextcloud15-dont-chmod.patch)58
4 files changed, 61 insertions, 41 deletions
diff --git a/community/nextcloud/APKBUILD b/community/nextcloud/APKBUILD
index 5e4597be332..31f2e0c283a 100644
--- a/community/nextcloud/APKBUILD
+++ b/community/nextcloud/APKBUILD
@@ -1,23 +1,25 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
pkgname=nextcloud
-pkgver=18.0.6
+pkgver=19.0.0
pkgrel=0
pkgdesc="A safe home for all your data"
url="http://nextcloud.com"
arch="noarch"
license="AGPL-3.0-only"
_php=php7
-_php_mods="-ctype -curl -dom -gd -fileinfo -iconv -intl -json -mbstring -openssl
- -pcntl -posix -session -simplexml -xml -xmlreader -xmlwriter -zip"
+_php_mods="-bcmath -ctype -curl -dom -gd -fileinfo -gmp -iconv -intl -json
+ -mbstring -openssl -pcntl -posix -session -simplexml -xml -xmlreader
+ -xmlwriter -zip"
depends="ca-certificates $_php ${_php_mods//-/$_php-}"
makedepends="xmlstarlet"
-provides="$pkgname-dav=$pkgver-r$pkgrel
+provides="$pkgname-contactsinteraction=$pkgver-r$pkgrel
+ $pkgname-dav=$pkgver-r$pkgrel
$pkgname-files=$pkgver-r$pkgrel
- $pkgname-provisioning_api=$pkgver-r$pkgrel
$pkgname-federatedfilesharing=$pkgver-r$pkgrel
- $pkgname-oauth2=$pkgver-r$pkgrel
$pkgname-lookup_server_connector=$pkgver-r$pkgrel
+ $pkgname-oauth2=$pkgver-r$pkgrel
+ $pkgname-provisioning_api=$pkgver-r$pkgrel
$pkgname-settings=$pkgver-r$pkgrel
$pkgname-twofactor_backupcodes=$pkgver-r$pkgrel
$pkgname-workflowengine=$pkgver-r$pkgrel
@@ -27,7 +29,7 @@ install="$pkgname.pre-install $pkgname.pre-upgrade $pkgname.post-upgrade
subpackages="$pkgname-doc $pkgname-initscript $pkgname-mysql $pkgname-pgsql $pkgname-sqlite
$pkgname-default-apps:_default_apps"
source="https://download.nextcloud.com/server/releases/nextcloud-$pkgver.zip
- nextcloud15-dont-chmod.patch
+ nextcloud19-dont-chmod.patch
nextcloud17-app-encryption-info-add-mcrypt.patch
dont-update-htaccess.patch
disable-integrity-check-as-default.patch
@@ -47,9 +49,9 @@ pkggroups="www-data"
builddir="$srcdir"/$pkgname
# List of bundled apps to separate into subpackages. Keep it in sync!
-# Note: Don't add "files", "dav", federatedfilesharing",
-# "lookup_server_connector", "provisioning_api", "oauth2",
-# "settings", "twofactor_backupcodes", "workflowengine"
+# Note: Don't add "contactsinteraction", "files", "dav",
+# "federatedfilesharing", "lookup_server_connector", "provisioning_api",
+# "oauth2", "settings", "twofactor_backupcodes", "workflowengine"
# here, these should be always installed.
_apps="accessibility
activity
@@ -237,12 +239,12 @@ _package_app() {
mv "$pkgdir"/$_appsdir/$appname "$subpkgdir"/$_appsdir/
}
-sha512sums="ca7e1cbdded193a7f24d11afa0c4de94a11e3631ee7f79c117a10bd49555c8ef3d4170170158280f2f634d53e2c4dec27453ab3522386fad92c5fa4e83d8c2c3 nextcloud-18.0.6.zip
-59151300c1153cad7fa2a1a972825c81a71df523b319b22799ce1bd846c1a63c7e37c608a125a98e4e733857cc65db9f329fafef7a5b1365d802c476450fce22 nextcloud15-dont-chmod.patch
-f84888bc2d5049ab490efea859dd68ab68b92fe1722c57d23d474362e363a05a39fac89f192ba0bbadfddb5ac5009737bf66f37983c1094fdd7cca1cb893390f nextcloud17-app-encryption-info-add-mcrypt.patch
+sha512sums="569c590af126c6be18f41d90a9f14c3d6ec97cf757191a052bded06ec5945e5593be05a86814fc5c170c0a2093542d669051fb4ccd1f4004fa54ca947a0af0a9 nextcloud-19.0.0.zip
+b7c80ad84e8f39ff99307130c9b081fa5b4d670359b9b4a03152ee677fa12389dacc311ec94ad27626461c21ed977d403fcc03c328a3d07b2e8f91ba5a4cbf9d nextcloud19-dont-chmod.patch
+56b187b5410452c5375b0503cfc154f86b8662f9590638c6975457675848b4251a8b1ed530741d815adfb4494ca44acc0ffea10471296be73026dcb4279aca60 nextcloud17-app-encryption-info-add-mcrypt.patch
aef3c92497d738d6968e0f0b0d415b4953500db24ae14af41ef972665cf7eff00cb6c53dc953845fdbb389c3c965a75b8b14b9247513c05cf4130fe1cfc61731 dont-update-htaccess.patch
d2100a837fef1eeae5f706650ab4c985d9e00f61efa5526ef76c7c1f5811c3906eb6c3c13c151eff9677a0c303faab64411a5a84d6792728bc520d2c618d7d5b disable-integrity-check-as-default.patch
-de1b433c2fb2582b599cb25e718e454fc4b93543a5a60eee39a03bcccf35d281594611395bdebe02319bedd9a894507eef97010ebdfca381e0f1a09df283d375 iconv-ascii-translit-not-supported.patch
+3fc3e06580a619d81b12f448976ffac34f0bb80fc73e9443fa213a73f160ba4b9bd14a26c134258ee12c04d8e103b46f4de10d7b11e4544a328878e57d436055 iconv-ascii-translit-not-supported.patch
df1a16414a278c205876ec86c210a02a9009954e2d4f9033ff3c9b76c371e2764ef3587db5a4b8f76302655c6c8688c8729d1685279a77d279d3839cc359fbcd use-external-docs-if-local-not-avail.patch
5f73cd9399fa484ef15bd47e803c93381deffbc7699eceadbb5c27e43b20156806d74e5021a64d28f0165ef87b519e962780651711a37bceb9f0b04455dfdce1 nextcloud-config.php
7388458a9e8b7afd3d3269718306410ffa59c3c23da4bef367a4d7f6d2570136fae9dd421b19c1441e7ffb15a5405e18bb5da67b1a15f9f45e8b98d3fda532ba nextcloud.logrotate
diff --git a/community/nextcloud/iconv-ascii-translit-not-supported.patch b/community/nextcloud/iconv-ascii-translit-not-supported.patch
index bb13a9514a7..e36f82b8c01 100644
--- a/community/nextcloud/iconv-ascii-translit-not-supported.patch
+++ b/community/nextcloud/iconv-ascii-translit-not-supported.patch
@@ -1,13 +1,19 @@
-iconv on Alpine does not support conversion to ASCII//TRANSLIT
+commit 70e75d985f5c6a7bea67210e85e6c6c9fea783f9
+Author: Leonardo Arena <rnalrd@alpinelinux.org>
+Date: Fri Jun 12 09:21:47 2020 +0000
+ iconv ascii translit not supported
+
+diff --git a/apps/user_ldap/lib/Access.php b/apps/user_ldap/lib/Access.php
+index 16013555..6c95f97c 100644
--- a/apps/user_ldap/lib/Access.php
+++ b/apps/user_ldap/lib/Access.php
-@@ -1318,7 +1318,7 @@
+@@ -1428,7 +1428,7 @@ class Access extends LDAPUtility {
}
// Transliteration to ASCII
- $transliterated = @iconv('UTF-8', 'ASCII//TRANSLIT', $name);
+ $transliterated = @iconv('UTF-8', 'ASCII', $name);
- if($transliterated !== false) {
+ if ($transliterated !== false) {
// depending on system config iconv can work or not
$name = $transliterated;
diff --git a/community/nextcloud/nextcloud17-app-encryption-info-add-mcrypt.patch b/community/nextcloud/nextcloud17-app-encryption-info-add-mcrypt.patch
index 0e1afdf240d..3554fa524ff 100644
--- a/community/nextcloud/nextcloud17-app-encryption-info-add-mcrypt.patch
+++ b/community/nextcloud/nextcloud17-app-encryption-info-add-mcrypt.patch
@@ -7,6 +7,6 @@ index 5050996..6df2d2b 100644
<dependencies>
<lib>openssl</lib>
+ <lib>mcrypt</lib>
- <nextcloud min-version="18" max-version="18"/>
+ <nextcloud min-version="19" max-version="19"/>
</dependencies>
diff --git a/community/nextcloud/nextcloud15-dont-chmod.patch b/community/nextcloud/nextcloud19-dont-chmod.patch
index b7474b9986d..990e42661fa 100644
--- a/community/nextcloud/nextcloud15-dont-chmod.patch
+++ b/community/nextcloud/nextcloud19-dont-chmod.patch
@@ -1,28 +1,54 @@
+commit fa2428c3200684467cb9bfe0b87c0656c040b812
+Author: Leonardo Arena <rnalrd@alpinelinux.org>
+Date: Wed Jun 10 10:31:31 2020 +0000
+
+ Don't chmod. The package takes care of setting the right permissions for directories and files
+
+diff --git a/lib/private/Config.php b/lib/private/Config.php
+index cbdbc5b2..1118981b 100644
--- a/lib/private/Config.php
+++ b/lib/private/Config.php
-@@ -240,9 +240,6 @@
- touch ($this->configFilePath);
+@@ -242,9 +242,6 @@ class Config {
+ touch($this->configFilePath);
$filePointer = fopen($this->configFilePath, 'r+');
- // Prevent others not to read the config
- chmod($this->configFilePath, 0640);
-
// File does not exist, this can happen when doing a fresh install
- if(!is_resource ($filePointer)) {
- // TODO fix this via DI once it is very clear that this doesn't cause side effects due to initialization order
+ if (!is_resource($filePointer)) {
+ throw new HintException(
+diff --git a/lib/private/Log/File.php b/lib/private/Log/File.php
+index 6be200f6..7db25286 100644
+--- a/lib/private/Log/File.php
++++ b/lib/private/Log/File.php
+@@ -82,9 +82,6 @@ class File extends LogDetails implements IWriter, IFileBased {
+ public function write(string $app, $message, int $level) {
+ $entry = $this->logDetailsAsJSON($app, $message, $level);
+ $handle = @fopen($this->logFile, 'a');
+- if ($this->logFileMode > 0 && (fileperms($this->logFile) & 0777) != $this->logFileMode) {
+- @chmod($this->logFile, $this->logFileMode);
+- }
+ if ($handle) {
+ fwrite($handle, $entry."\n");
+ fclose($handle);
+diff --git a/lib/private/TempManager.php b/lib/private/TempManager.php
+index 49d4ee94..b0943843 100644
--- a/lib/private/TempManager.php
+++ b/lib/private/TempManager.php
-@@ -95,7 +95,6 @@
- if($postFix !== '') {
+@@ -96,7 +96,6 @@ class TempManager implements ITempManager {
+ if ($postFix !== '') {
$fileNameWithPostfix = $this->buildFileNameWithSuffix($file, $postFix);
touch($fileNameWithPostfix);
- chmod($fileNameWithPostfix, 0600);
$this->current[] = $fileNameWithPostfix;
return $fileNameWithPostfix;
}
---- a/lib/private/legacy/util.php
-+++ b/lib/private/legacy/util.php
-@@ -1008,7 +1008,6 @@
+diff --git a/lib/private/legacy/OC_Util.php b/lib/private/legacy/OC_Util.php
+index 71f6edba..216abdf8 100644
+--- a/lib/private/legacy/OC_Util.php
++++ b/lib/private/legacy/OC_Util.php
+@@ -1004,7 +1004,6 @@ class OC_Util {
. ' cannot be listed by other users.');
$perms = substr(decoct(@fileperms($dataDirectory)), -3);
if (substr($perms, -1) !== '0') {
@@ -30,17 +56,3 @@
clearstatcache();
$perms = substr(decoct(@fileperms($dataDirectory)), -3);
if ($perms[2] !== '0') {
-diff --git a/lib/private/Log/File.php b/lib/private/Log/File.php
-index 6810e25..3a9e872 100644
---- a/lib/private/Log/File.php
-+++ b/lib/private/Log/File.php
-@@ -137,9 +137,6 @@ class File implements IWriter, IFileBased {
- }
- $entry = json_encode($entry, JSON_PARTIAL_OUTPUT_ON_ERROR);
- $handle = @fopen($this->logFile, 'a');
-- if ($this->logFileMode > 0 && (fileperms($this->logFile) & 0777) != $this->logFileMode) {
-- @chmod($this->logFile, $this->logFileMode);
-- }
- if ($handle) {
- fwrite($handle, $entry."\n");
- fclose($handle);