aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-10-13 10:20:14 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-10-13 10:26:32 +0000
commitc827024e9a033cfbbd534fdbbecc9265415a0653 (patch)
tree554e52a3325eba3da3e2302ac53586f52bfe1c12
parent91453c6f810e4f3075bdce8ad7d01571e6b5d56a (diff)
testing/monado: upgrade to 0.3.0_git20201012
Makes it work with the libsurvive version that we use
-rw-r--r--testing/monado/APKBUILD14
-rw-r--r--testing/monado/fix-compilation-on-musl.patch33
2 files changed, 6 insertions, 41 deletions
diff --git a/testing/monado/APKBUILD b/testing/monado/APKBUILD
index 643491044f3..57cd40b9cf2 100644
--- a/testing/monado/APKBUILD
+++ b/testing/monado/APKBUILD
@@ -1,8 +1,9 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=monado
-pkgver=0.3.0
-pkgrel=1
+pkgver=0.3.0_git20201012
+pkgrel=0
+_commit="d959bea54af2aff65926b823d6792eb24d8bc640"
pkgdesc="The open source OpenXR runtime"
url="https://monado.freedesktop.org"
arch="all !mips64" # blocked by xr-hardware
@@ -30,10 +31,8 @@ makedepends="
wayland-protocols
zlib-dev
"
-source="https://gitlab.freedesktop.org/monado/monado/-/archive/v$pkgver/monado-v$pkgver.tar.gz
- fix-compilation-on-musl.patch
- "
-builddir="$srcdir/$pkgname-v$pkgver"
+source="https://gitlab.freedesktop.org/monado/monado/-/archive/$_commit/monado-$_commit.tar.gz"
+builddir="$srcdir/$pkgname-$_commit"
build() {
abuild-meson . output \
@@ -49,5 +48,4 @@ package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="2faa4e5e5f64bcd2213abb312e6e3b1fad6a0fa1930411f97c82a24f03f869fc67633c8089229f7e7e06f0399553e9b7aec71a53815f24aeddeabfedbfa67694 monado-v0.3.0.tar.gz
-3fecf3f03d298991b916db2c783b753fd9abe66e7bd33304a57c36aaf27f9e35236b8ea05676edb280326c02fcf2ca6acf7d1b10e329e16feea8b1c24c43e428 fix-compilation-on-musl.patch"
+sha512sums="562124ec8f60f6930e9ea343b1244665c49fe0586dfa78da49b63568d4ecf5cb178d7e877d803fea209d5dd74ac4843358351076613cd5ed106be4a85501248e monado-d959bea54af2aff65926b823d6792eb24d8bc640.tar.gz"
diff --git a/testing/monado/fix-compilation-on-musl.patch b/testing/monado/fix-compilation-on-musl.patch
deleted file mode 100644
index 1ae80e98944..00000000000
--- a/testing/monado/fix-compilation-on-musl.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 71f912ffc57548c8f47f1567844ed41a5f05bc83 Mon Sep 17 00:00:00 2001
-From: Bart Ribbers <bribbers@disroot.org>
-Date: Wed, 16 Sep 2020 10:44:06 +0200
-Subject: [PATCH] Fix compilation on Musl
-
-Without this fix, compilation failed on Musl due to ssize_t being an
-unknown type
-
-In file included from ../src/xrt/state_trackers/prober/p_prober.c:15:
-../src/xrt/state_trackers/prober/p_prober.h:67:2: error: unknown type name 'ssize_t'
- 67 | ssize_t interface;
- | ^~~~~~~
----
- src/xrt/state_trackers/prober/p_prober.h | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/src/xrt/state_trackers/prober/p_prober.h b/src/xrt/state_trackers/prober/p_prober.h
-index bf7a3417..793c14a4 100644
---- a/src/xrt/state_trackers/prober/p_prober.h
-+++ b/src/xrt/state_trackers/prober/p_prober.h
-@@ -23,6 +23,9 @@
- #include <libuvc/libuvc.h>
- #endif
-
-+#ifndef __KERNEL__
-+#include <sys/types.h>
-+#endif
-
- /*
- *
---
-GitLab
-