aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-08-12 02:01:57 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-08-28 08:40:43 +0000
commitc973387777797c2a8a0da5e1d0d335cd887a4235 (patch)
tree9a47fed56a7a6b56a93a82e3215595dd999e68f4
parentb506a63a0ac97f2c5c1ad9ef3435c898f165e2d8 (diff)
main/libgpg-error: add test suite and modernise APKBUILD
-rw-r--r--main/libgpg-error/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/main/libgpg-error/APKBUILD b/main/libgpg-error/APKBUILD
index f5a86080a4e..d07e7b08798 100644
--- a/main/libgpg-error/APKBUILD
+++ b/main/libgpg-error/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libgpg-error
pkgver=1.27
-pkgrel=0
+pkgrel=1
pkgdesc="Support library for libgcrypt"
url="http://www.gnupg.org"
arch="all"
@@ -11,7 +11,7 @@ depends=""
depends_dev=""
makedepends=""
install=""
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lisp"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lisp:lisp:noarch"
source="ftp://ftp.franken.de/pub/crypt/mirror/ftp.gnupg.org/gcrypt/$pkgname/$pkgname-$pkgver.tar.bz2
"
@@ -25,14 +25,18 @@ build () {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --disable-nls \
- || return 1
- make || return 1
+ --disable-nls
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
+ make -j1 DESTDIR="$pkgdir" install
}
lisp() {