aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-06-24 13:07:16 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-06-24 14:56:26 +0000
commitcad34f603980e00873f3be0cf9363f38ec1a50d2 (patch)
treef756256f1ba1ec97a468985bbc4f15ddc4baef25
parentd5781dbe76592828ce37fc139d9db255b832df2f (diff)
community/plasma-nm: backport fix for KDE bug 423093
-rw-r--r--community/plasma-nm/APKBUILD9
-rw-r--r--community/plasma-nm/fix-423093.patch36
2 files changed, 42 insertions, 3 deletions
diff --git a/community/plasma-nm/APKBUILD b/community/plasma-nm/APKBUILD
index 6c22a19673f..d0aa8f72e0b 100644
--- a/community/plasma-nm/APKBUILD
+++ b/community/plasma-nm/APKBUILD
@@ -2,14 +2,16 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-nm
pkgver=5.19.2
-pkgrel=0
+pkgrel=1
pkgdesc="Plasma applet written in QML for managing network connections"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
url="https://www.kde.org/workspaces/plasmadesktop/"
license="(LGPL-2.1-only OR LGPL-3.0-only) AND LGPL-2.0-or-later"
depends="kirigami2 networkmanager"
makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev ki18n-dev kwindowsystem-dev kservice-dev kcompletion-dev kwidgetsaddons-dev kio-dev kcoreaddons-dev kwallet-dev kconfigwidgets-dev kiconthemes-dev solid-dev kdbusaddons-dev knotifications-dev plasma-framework-dev kdeclarative-dev qca-dev networkmanager-qt-dev modemmanager-qt-dev mobile-broadband-provider-info"
-source="https://download.kde.org/stable/plasma/$pkgver/plasma-nm-$pkgver.tar.xz"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-nm-$pkgver.tar.xz
+ fix-423093.patch
+ "
subpackages="$pkgname-lang $pkgname-mobile"
build() {
@@ -44,4 +46,5 @@ mobile() {
"$pkgdir"/usr/share/kservices5/wifisettings.desktop \
"$subpkgdir"/usr/share/kservices5/
}
-sha512sums="369c8d869b83db86e8c26054c788c44f2b0ca6eebac8f1fec3020ae77f4be62df0fe408fd1c9bc60c23012a75a97546d4f8ffda0483d4acdef1b6e902822d79b plasma-nm-5.19.2.tar.xz"
+sha512sums="369c8d869b83db86e8c26054c788c44f2b0ca6eebac8f1fec3020ae77f4be62df0fe408fd1c9bc60c23012a75a97546d4f8ffda0483d4acdef1b6e902822d79b plasma-nm-5.19.2.tar.xz
+c5fc0ceee9ce3a512fc2ba7455704bfa5ba7d1e01df8b09d56f413ec3652e6689454c68cd3802c533932eb30c8fd2023b33afebe61fb8ef90bf501f806cb66b7 fix-423093.patch"
diff --git a/community/plasma-nm/fix-423093.patch b/community/plasma-nm/fix-423093.patch
new file mode 100644
index 00000000000..243e69eddc9
--- /dev/null
+++ b/community/plasma-nm/fix-423093.patch
@@ -0,0 +1,36 @@
+Requested to backport by upstream to fix KDE bug 423093
+https://bugs.kde.org/show_bug.cgi?id=423093
+
+Has been merged upstream already and will be unnecessary with the
+release of the next full Plasma release
+
+From 271332cfc19ede398854113d037abfb35503179f Mon Sep 17 00:00:00 2001
+From: Nate Graham <nate@kde.org>
+Date: Thu, 18 Jun 2020 15:34:40 +0000
+Subject: [PATCH] [WIP] [applet] Fix inline password field component not
+ working properly
+
+BUG: 423093
+FIXED-IN: 5.20
+---
+ applet/contents/ui/ConnectionItem.qml | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/applet/contents/ui/ConnectionItem.qml b/applet/contents/ui/ConnectionItem.qml
+index 98240928..06c7ab25 100644
+--- a/applet/contents/ui/ConnectionItem.qml
++++ b/applet/contents/ui/ConnectionItem.qml
+@@ -231,8 +231,8 @@ PlasmaExtras.ExpandableListItem {
+ if (!predictableWirelessPassword && !Uuid) {
+ handler.addAndActivateConnection(DevicePath, SpecificPath)
+ } else if (connectionItem.customExpandedViewContent == passwordDialogComponent) {
+- if (passwordDialogComponent.password != "") {
+- handler.addAndActivateConnection(DevicePath, SpecificPath, passwordDialogComponent.password)
++ if (connectionItem.customExpandedViewContentItem.password != "") {
++ handler.addAndActivateConnection(DevicePath, SpecificPath, connectionItem.customExpandedViewContentItem.password)
+ connectionItem.customExpandedViewContent = detailsComponent
+ connectionItem.collapse()
+ } else {
+--
+GitLab
+