aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2020-04-13 12:22:45 -0400
committerRasmus Thomsen <oss@cogitri.dev>2020-04-26 19:27:03 +0000
commitcd957617ffe46637698464f855fb876d0c6288db (patch)
treef4f4cb34d7ceded563612733e4552aee82769afd
parent722f6588471469f58795aac913c5fa165bf872b2 (diff)
testing/ttf-anonymous-pro: new aport
https://www.marksimonson.com/fonts/view/anonymous-pro A family of four fixed-width fonts designed especially with coding in mind testing/
-rw-r--r--testing/ttf-anonymous-pro/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/ttf-anonymous-pro/APKBUILD b/testing/ttf-anonymous-pro/APKBUILD
new file mode 100644
index 00000000000..23514999c74
--- /dev/null
+++ b/testing/ttf-anonymous-pro/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Galen Abell <galen@galenabell.com>
+# Maintainer: Galen Abell <galen@galenabell.com>
+pkgname=ttf-anonymous-pro
+pkgver=1.002
+pkgrel=0
+pkgdesc="A family of four fixed-width fonts designed especially with coding in mind"
+url="https://www.marksimonson.com/fonts/view/anonymous-pro"
+arch="noarch"
+license="OFL-1.1"
+depends="fontconfig"
+options="!check" # no tests
+source="https://www.marksimonson.com/assets/content/fonts/AnonymousPro-$pkgver.zip"
+builddir="$srcdir/AnonymousPro-$pkgver.001"
+
+build() {
+ :
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/fonts/TTF
+ install -m644 "$builddir"/*.ttf \
+ "$pkgdir"/usr/share/fonts/TTF/
+}
+sha512sums="7606d520ad79fbf4e13d676c1aff61b764dce74e170f8783b8e606f7907c4b8db0871e5568504d15aa23ca26e925ada4eb6b60fcf27171dccee0d3d32d9a92a1 AnonymousPro-1.002.zip"