aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-09-08 19:28:51 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-19 10:51:29 +0000
commitcdbb8f7163ef56e9c57345b9a289e53fb5655da2 (patch)
tree664b98d9c1dd401832130296b1febb2a35f394cb
parentcd8c6c94e2e43f751944a198fd04d1f2ecfd623a (diff)
main/xineramaproto: modernise, deps, no test
-rw-r--r--main/xineramaproto/APKBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/main/xineramaproto/APKBUILD b/main/xineramaproto/APKBUILD
index 277ce0a9d17..d6bbce2c705 100644
--- a/main/xineramaproto/APKBUILD
+++ b/main/xineramaproto/APKBUILD
@@ -1,34 +1,33 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xineramaproto
pkgver=1.2.1
-pkgrel=2
+pkgrel=3
pkgdesc="X11 Xinerama extension wire protocol"
url="http://xorg.freedesktop.org/"
arch="noarch"
license="custom"
+options="!check" # No test suite.
depends=""
-makedepends=""
+makedepends="util-macros"
source="http://www.x.org/releases/individual/proto/$pkgname-$pkgver.tar.bz2"
-_builddir="$srcdir/$pkgname-$pkgver"
-
prepare() {
- cd "$_builddir"
- update_config_sub || return 1
+ cd "$builddir"
+ update_config_sub
+ default_prepare
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
- --prefix=/usr \
- || return 1
- make || return 1
+ --prefix=/usr
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
sha512sums="ec2194c9bcad3f0f3eb3e9298792272213aa032ae9d6c00dcad567f31d7278a8c676fc67f47aae1a6deef5bade0b204346ed16da4a4c4d5a507c04d109d3dbb3 xineramaproto-1.2.1.tar.bz2"