aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2021-04-11 20:47:40 +0200
committerRasmus Thomsen <oss@cogitri.dev>2021-04-11 20:47:40 +0200
commitcdf003fc1824d052c3cf227bae2ab73b25a09cf0 (patch)
tree620b2a35cc5d5d1702dbfb094ff7a02c0ac85ad6
parent336a51a17a7bc75b779ded99672b2c9febbc2ebf (diff)
community/graphene: add patch to fix touch issues in gnome-shell
See https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/3976 for more details fixes #2574
-rw-r--r--community/graphene/APKBUILD8
-rw-r--r--community/graphene/fix-gnome-shell-touch-issues.patch14
2 files changed, 19 insertions, 3 deletions
diff --git a/community/graphene/APKBUILD b/community/graphene/APKBUILD
index 1ddd775558c..ddd0dfc56ab 100644
--- a/community/graphene/APKBUILD
+++ b/community/graphene/APKBUILD
@@ -2,14 +2,15 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=graphene
pkgver=1.10.6
-pkgrel=0
+pkgrel=1
pkgdesc="A thin layer of graphic data types"
url="http://ebassi.github.io/graphene/"
arch="all"
license="MIT"
makedepends="meson glib-dev gobject-introspection-dev"
subpackages="$pkgname-dev"
-source="https://github.com/ebassi/graphene/releases/download/$pkgver/graphene-$pkgver.tar.xz"
+source="https://github.com/ebassi/graphene/releases/download/$pkgver/graphene-$pkgver.tar.xz
+ fix-gnome-shell-touch-issues.patch"
build() {
abuild-meson \
@@ -26,4 +27,5 @@ package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="075e8c712509655d0614258a7fd2943e67a9642334cdabdc15d2489a88c961e278f7464a513080cd287f5371c7ece8ceb7565d1718a8b71fea4a4977f82aeb72 graphene-1.10.6.tar.xz"
+sha512sums="075e8c712509655d0614258a7fd2943e67a9642334cdabdc15d2489a88c961e278f7464a513080cd287f5371c7ece8ceb7565d1718a8b71fea4a4977f82aeb72 graphene-1.10.6.tar.xz
+07f2e9ed7099f1e3f785f7b53078e4ea642739bfb23f4c3353c42d72690df3368fac28d70197eb28dbf02ddd1832d89e41ea83c1591d54a57fccafa3e9b4bedc fix-gnome-shell-touch-issues.patch"
diff --git a/community/graphene/fix-gnome-shell-touch-issues.patch b/community/graphene/fix-gnome-shell-touch-issues.patch
new file mode 100644
index 00000000000..d33ed720fc0
--- /dev/null
+++ b/community/graphene/fix-gnome-shell-touch-issues.patch
@@ -0,0 +1,14 @@
+https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/3976#note_1079639
+diff --git a/src/graphene-ray.c b/src/graphene-ray.c
+index 66c3393..9151300 100644
+--- a/src/graphene-ray.c
++++ b/src/graphene-ray.c
+@@ -563,7 +563,7 @@ graphene_ray_intersect_box (const graphene_ray_t *r,
+ #else
+ if (ty_min > tx_min || fpclassify (tx_min) == FP_NAN)
+ tx_min = ty_min;
+- if (ty_max > tx_max || fpclassify (tx_max) == FP_NAN)
++ if (ty_max < tx_max || fpclassify (tx_max) == FP_NAN)
+ tx_max = ty_max;
+ #endif
+