aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-10-02 16:41:51 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-10-02 21:21:13 +0000
commitcf3286c1a513b125efb97d4519e8aff96a2566aa (patch)
treef190da31f196d769e92b0aadb423835fd0d39600
parentddbba9be0d49e21e094fafaa3405f4ca3264ed8c (diff)
testing/libxml++: upgrade to 3.2.2
-rw-r--r--testing/libxml++/APKBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/testing/libxml++/APKBUILD b/testing/libxml++/APKBUILD
index 973ec0c7225..0c9be67e674 100644
--- a/testing/libxml++/APKBUILD
+++ b/testing/libxml++/APKBUILD
@@ -1,28 +1,32 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=libxml++
-pkgver=3.2.0
+pkgver=3.2.2
pkgrel=0
-pkgdesc="libbxml++ is a C++ wrapper for the libxml XML parser library."
+pkgdesc="C++ wrapper for the libxml XML parser library"
url="http://libxmlplusplus.sourceforge.net/"
arch="all"
license="LGPL-2.1-or-later"
-makedepends="libxml2-dev glibmm-dev perl-dev"
+makedepends="meson libxml2-dev glibmm-dev python3 perl doxygen graphviz"
subpackages="$pkgname-dev $pkgname-doc"
source="https://download.gnome.org/sources/libxml++/${pkgver%.[0-9]*}/libxml++-$pkgver.tar.xz"
build() {
- ./configure --prefix=/usr
- make
+ abuild-meson \
+ -Dbuild-tests=true \
+ -Dbuild-examples=false \
+ -Dbuild-documentation=true \
+ . output
+ meson compile ${JOBS:+-j ${JOBS}} -C output
}
-package() {
- make DESTDIR="$pkgdir" install
- ln -s libxml++-3.0.pc "$pkgdir"/usr/lib/pkgconfig/libxml++.pc
+check() {
+ meson test --no-rebuild -v -C output
}
-check() {
- make check
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+ ln -s libxml++-3.0.pc "$pkgdir"/usr/lib/pkgconfig/libxml++.pc
}
-sha512sums="003df3d3ab1955b6facc133c9322e4a2b3b8fe6e2a5309549cef1ce088b0fca0c6546a3a4deb33c61c2169797229ee1df9ef6e0233160ee5534cd39ba29afd64 libxml++-3.2.0.tar.xz"
+sha512sums="c000d438aae487b92de2a1c60277d5e3ad3bf93824fc8fa99684778ea2334a45bf621f8d253190bdadedc591772d9beee53a98ebc3e20015d2ca68e097c0a253 libxml++-3.2.2.tar.xz"