aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-11-28 10:59:26 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-11-30 14:27:59 +0000
commitd087cbfa8832b3b5565582c1b4fe6e6997399530 (patch)
tree276e7b6c33aab964366897f0d496a08109a9eb97
parenta5e1d24aa3c9b1b37f7bb8725f76e9245897d1d7 (diff)
community/wireshark: upgrade to 3.4.0
See: #12141
-rw-r--r--community/wireshark/APKBUILD11
-rw-r--r--community/wireshark/disable-tests.patch35
2 files changed, 43 insertions, 3 deletions
diff --git a/community/wireshark/APKBUILD b/community/wireshark/APKBUILD
index 5aafdd0b9c9..3f613e95223 100644
--- a/community/wireshark/APKBUILD
+++ b/community/wireshark/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wireshark
# 3.3.x is an experimental release for 3.4.x, stay on stable
-pkgver=3.2.7
+pkgver=3.4.0
pkgrel=0
pkgdesc="Network protocol analyzer"
url="https://www.wireshark.org"
@@ -38,9 +38,13 @@ checkdepends="py3-pytest py3-pytest-xdist"
subpackages="$pkgname-dev $pkgname-doc $pkgname-common tshark"
source="https://www.wireshark.org/download/src/wireshark-$pkgver.tar.xz
fix-udpdump.patch
+ disable-tests.patch
"
# secfixes:
+# 3.4.0-r0:
+# - CVE-2020-26575
+# - CVE-2020-28030
# 3.2.7-r0:
# - CVE-2020-25863
# - CVE-2020-25862
@@ -288,5 +292,6 @@ tshark() {
mv "$pkgdir"/usr/bin/tshark "$subpkgdir"/usr/bin/tshark
}
-sha512sums="c17913fe6c193ccc6b0dbf86932d625a1f3b670aef805296e5db2639118218e06d513910ad50ab3926204f94a0010425b0d498176f987516d64fdd6a52d2517b wireshark-3.2.7.tar.xz
-287159576be76fc8afbce450a53f969bbd519321e038c812b96857ca08c352052dbbfaa9208d54ed30d7a0c9ca4192b83c8865de60562c4490d99d75c61ede0b fix-udpdump.patch"
+sha512sums="02070db23c64e1efe42b83cdcd7b52fb9b247e653da0aa12dc21a4283272fea0a135f4b0c5641197840bef88e52785d64a860c9fcfe1bcbaceb016c5258c9649 wireshark-3.4.0.tar.xz
+287159576be76fc8afbce450a53f969bbd519321e038c812b96857ca08c352052dbbfaa9208d54ed30d7a0c9ca4192b83c8865de60562c4490d99d75c61ede0b fix-udpdump.patch
+3c907a037504d39a56766db37eecc9d5f968fdcb90c431e099b3f77e4ffc52fb65cb6c3896406aa939a846d526daf5676693ae5c2ff933e1d878e39ac074417a disable-tests.patch"
diff --git a/community/wireshark/disable-tests.patch b/community/wireshark/disable-tests.patch
new file mode 100644
index 00000000000..5ba7a76d1e4
--- /dev/null
+++ b/community/wireshark/disable-tests.patch
@@ -0,0 +1,35 @@
+Upstream: Not applicable but tell them that sdjournal is not linux specific
+Reason: Disable tests for features we don't have or don't enable
+
+diff --git a/test/suite_extcaps.py b/test/suite_extcaps.py
+index d086d92..a57e01d 100644
+--- a/test/suite_extcaps.py
++++ b/test/suite_extcaps.py
+@@ -59,10 +59,6 @@ class case_extcaps(subprocesstest.SubprocessTestCase):
+ ''' extcap interface tests for androiddump '''
+ check_extcap_execution("androiddump", always_present=False)
+
+- def test_ciscodump(self, check_extcap_execution):
+- ''' extcap interface tests for ciscodump '''
+- check_extcap_execution("ciscodump")
+-
+ def test_dpauxmon(self, check_extcap_execution):
+ ''' extcap interface tests for dpauxmon '''
+ if not sys.platform.startswith('linux'):
+@@ -73,16 +69,6 @@ class case_extcaps(subprocesstest.SubprocessTestCase):
+ ''' extcap interface tests for randpktdump '''
+ check_extcap_execution("randpktdump")
+
+- def test_sdjournal(self, check_extcap_execution):
+- ''' extcap interface tests for sdjournal '''
+- if not sys.platform.startswith('linux'):
+- fixtures.skip('sdjournal is available on Linux only')
+- check_extcap_execution("sdjournal")
+-
+- def test_sshdump(self, check_extcap_execution):
+- ''' extcap interface tests for sshdump '''
+- check_extcap_execution("sshdump")
+-
+ def test_udpdump(self, check_extcap_execution):
+ ''' extcap interface tests for udpdump '''
+ check_extcap_execution("udpdump")