aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2021-02-08 02:08:38 -0300
committerLeo <thinkabit.ukim@gmail.com>2021-02-08 05:23:38 +0000
commitd0a7919637b52e0959a24996bc5a18365b7240c0 (patch)
tree065343baf6a832d10c4f6ab5df711e9afd701c96
parent158c4176d66c72a7afe79e600198c54290cfb12a (diff)
community/lightdm: fix location of dbus configuration
-rw-r--r--community/lightdm/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/community/lightdm/APKBUILD b/community/lightdm/APKBUILD
index 5f722be7d03..94d5ae0891c 100644
--- a/community/lightdm/APKBUILD
+++ b/community/lightdm/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lightdm
pkgver=1.30.0
-pkgrel=3
-pkgdesc="A cross-desktop display manager"
+pkgrel=4
+pkgdesc="cross-desktop display manager"
url="https://www.freedesktop.org/wiki/Software/LightDM"
arch="all !s390x !mips !mips64" # gnome-themes-standard missing due to librsvg
license="GPL-3.0-or-later"
@@ -56,6 +56,10 @@ package() {
install -Dm755 "$srcdir"/lightdm.initd "$pkgdir"/etc/init.d/lightdm
install -o lightdm -g lightdm -d "$pkgdir"/var/lib/lightdm-data
rm -rf "$pkgdir"/etc/apparmor.d
+
+ # Fix location of dbus configuration from $sysconfdir to $datadir
+ mv "$pkgdir"/etc/dbus-1/system.d "$pkgdir"/usr/share/dbus-1/system.d
+ rm -rf "$pkgdir"/etc/dbus-1
}
qt5() {