aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2021-02-06 17:20:21 -0300
committerLeo <thinkabit.ukim@gmail.com>2021-02-06 21:30:47 +0000
commitd152a161bd05246ae63cf39d737ff3e31128c2a8 (patch)
tree530e941ec974dc92b72976a5f4adae5fb13ef181
parentf879d2f6ef05ba7c69fdac253547fb006d68ccb7 (diff)
main/pigz: upgrade to 2.6
-rw-r--r--main/pigz/APKBUILD9
-rw-r--r--main/pigz/f310c0868634a1dbacdcdcb2dbce9501a8a87868.patch49
2 files changed, 3 insertions, 55 deletions
diff --git a/main/pigz/APKBUILD b/main/pigz/APKBUILD
index d21889830dd..86662c5e2ea 100644
--- a/main/pigz/APKBUILD
+++ b/main/pigz/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer:
pkgname=pigz
-pkgver=2.5
+pkgver=2.6
pkgrel=0
pkgdesc="Parallel implementation of gzip"
url="https://zlib.net/pigz/"
@@ -9,9 +9,7 @@ arch="all"
license="Zlib"
makedepends="zlib-dev"
subpackages="$pkgname-doc"
-source="https://zlib.net/pigz/pigz-$pkgver.tar.gz
- f310c0868634a1dbacdcdcb2dbce9501a8a87868.patch
- "
+source="https://zlib.net/pigz/pigz-$pkgver.tar.gz"
build() {
make
@@ -28,5 +26,4 @@ package() {
install -Dm644 pigz.1 -t "$pkgdir"/usr/share/man/man1
}
-sha512sums="8f52900b8664c67b5b1813ac2f6e226d899c72ba19eefd6424181dc4dc0416d38ad3c7e5fe3dce6bdb58f5ac34ec0269f846c43f9aef6f69a121713113c1643a pigz-2.5.tar.gz
-c5ab648fc6743cb8785049caeb6edd2a1c0fb2124c1dd0604ef41d4ca499efb16d25dc7d87582fca9cdbfc694b558de16b05ddc3856f7eb3722c1ee00c6c1404 f310c0868634a1dbacdcdcb2dbce9501a8a87868.patch"
+sha512sums="04d2e44bc7a7eb061c3c48100ce5b8fc79931aeac72340abd768fd2a4499ff1004e2bc009772fc2003a4c599f6e90f3abc8bef5c377d6397f1c8e9f7c49f95e2 pigz-2.6.tar.gz"
diff --git a/main/pigz/f310c0868634a1dbacdcdcb2dbce9501a8a87868.patch b/main/pigz/f310c0868634a1dbacdcdcb2dbce9501a8a87868.patch
deleted file mode 100644
index 8c1fe2d820a..00000000000
--- a/main/pigz/f310c0868634a1dbacdcdcb2dbce9501a8a87868.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From f310c0868634a1dbacdcdcb2dbce9501a8a87868 Mon Sep 17 00:00:00 2001
-From: Mark Adler <madler@alumni.caltech.edu>
-Date: Sun, 24 Jan 2021 21:39:26 -0800
-Subject: [PATCH] Fix usage of x2nmodp() when compiling for no threads.
-
----
- pigz.c | 8 ++++++--
- 1 file changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/pigz.c b/pigz.c
-index e5a094a..7430e1e 100644
---- a/pigz.c
-+++ b/pigz.c
-@@ -545,7 +545,9 @@ local struct {
- int procs; // maximum number of compression threads (>= 1)
- int setdict; // true to initialize dictionary in each thread
- size_t block; // uncompressed input size per thread (>= 32K)
-+#ifndef NOTHREAD
- crc_t shift; // pre-calculated CRC-32 shift for length block
-+#endif
-
- // saved gzip/zip header data for decompression, testing, and listing
- time_t stamp; // time stamp from gzip header
-@@ -4286,13 +4288,13 @@ local void defaults(void) {
- // blocksplittingmax = 15
- ZopfliInitOptions(&g.zopts);
- #endif
-+ g.block = 131072UL; // 128K
- #ifdef NOTHREAD
- g.procs = 1;
- #else
- g.procs = nprocs(8);
--#endif
-- g.block = 131072UL; // 128K
- g.shift = x2nmodp(g.block, 3);
-+#endif
- g.rsync = 0; // don't do rsync blocking
- g.setdict = 1; // initialize dictionary each thread
- g.verbosity = 1; // normal message level
-@@ -4480,7 +4482,9 @@ local int option(char *arg) {
- if (get == 1) {
- n = num(arg);
- g.block = n << 10; // chunk size
-+#ifndef NOTHREAD
- g.shift = x2nmodp(g.block, 3);
-+#endif
- if (g.block < DICT)
- throw(EINVAL, "block size too small (must be >= 32K)");
- if (n != g.block >> 10 ||