aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-03-26 20:59:00 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-05-06 20:36:42 +0000
commitd21bec9a86f8d4ed72953f2ce199e8ee7f955e0a (patch)
treef1429fb25648380c1ccaf976f083b90acd51563a
parent35a21f3f080234a7e8e3c75d13e736d8905007fb (diff)
testing/py3-speechpy: new aport
-rw-r--r--testing/py3-speechpy/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-speechpy/APKBUILD b/testing/py3-speechpy/APKBUILD
new file mode 100644
index 00000000000..3fe4df1b72b
--- /dev/null
+++ b/testing/py3-speechpy/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-speechpy
+pkgver=2.4
+pkgrel=0
+pkgdesc="A Library for Speech Processing and Recognition"
+url="http://speechpy.readthedocs.io/en/latest/"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-numpy py3-scipy"
+makedepends="py3-setuptools py3-numpy-dev"
+source="https://pypi.python.org/packages/source/s/speechpy-fast/speechpy-fast-$pkgver.tar.gz"
+options="!check" # No tests
+builddir="$srcdir/speechpy-fast-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="0e797c06953174e847eee4e2f41031e6605242dea713563ce402537f9392769a4893fc6aa0903d403174691dc5161805910529dc97bb54e9df460eba5c6b0503 speechpy-fast-2.4.tar.gz"