aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2020-02-22 23:48:39 +0100
committerJakub Jirutka <jakub@jirutka.cz>2020-02-22 23:49:34 +0100
commitd2c0530b81c707904b9e254fce1eb88c4984f7a6 (patch)
tree91be69017c15fbfd9d4112878fb7c646660a709a
parentf21cc51c4208f76c72f665314d9ae8051d74a3c4 (diff)
community/lua-http: upgrade to 0.3
-rw-r--r--community/lua-http/APKBUILD15
-rw-r--r--community/lua-http/lpeg_patterns-0.5.patch37
2 files changed, 6 insertions, 46 deletions
diff --git a/community/lua-http/APKBUILD b/community/lua-http/APKBUILD
index fa9f5709581..e2dfdc6f87b 100644
--- a/community/lua-http/APKBUILD
+++ b/community/lua-http/APKBUILD
@@ -1,19 +1,17 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=lua-http
-pkgver=0.2
-pkgrel=4
+pkgver=0.3
+pkgrel=0
pkgdesc="HTTP Library for Lua that supports HTTP(S) 1.0, 1.1 and 2.0"
url="https://github.com/daurnimator/lua-http"
arch="noarch"
license="MIT"
-depends="lua-cqueues lua-basexx lua-fifo lua-lpeg lua-lpeg_patterns>=0.5 lua-ossl"
+depends="lua-binaryheap lua-cqueues lua-basexx lua-fifo lua-lpeg lua-lpeg_patterns>=0.5 lua-ossl"
checkdepends="lua-busted lua5.1-compat53 lua5.2-compat53 lua5.1-bit32"
makedepends=""
subpackages=""
-source="$pkgname-$pkgver.tar.gz::https://github.com/daurnimator/$pkgname/archive/v$pkgver.tar.gz
- lpeg_patterns-0.5.patch
- "
+source="$pkgname-$pkgver.tar.gz::https://github.com/daurnimator/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
case "$CARCH" in
@@ -22,7 +20,7 @@ case "$CARCH" in
# FIXME: Some tests fail with "Address not available".
# and ppc64le hangs
aarch64|arm*|ppc64le) options="!check";;
- *) checkdepends="$checkdepends luajit" _luajit="jit";;
+ *) checkdepends="$checkdepends luajit"; _luajit="jit";;
esac
_luaversions="5.1 5.2 5.3"
@@ -66,5 +64,4 @@ _subpackage() {
echo 'rock_manifest = {}' > "$rockdir"/rock_manifest
}
-sha512sums="ed71ac09277e8602e3d4954541f06c09ef444db20e5b4e39a17b9ed4893046b1442969902c0ba84fc4c3c922a6d1c8ebf853fceda261b12bf10ea9aa24389587 lua-http-0.2.tar.gz
-9ce9038c69bb6d4730cf7717fde9c47447eafbe050dd88a6e60930a9cca63f80598f379885627b06f45e744fe6d59531c58d25565834a1963c81b884560710cc lpeg_patterns-0.5.patch"
+sha512sums="5728848849e8d3e99328abdc6aff3034a708f0e5884e8718a9266900a561a37850e2bf911e9cbd0d4d538799e1fd8bb4fd66008f4787011f5802b259d51f8281 lua-http-0.3.tar.gz"
diff --git a/community/lua-http/lpeg_patterns-0.5.patch b/community/lua-http/lpeg_patterns-0.5.patch
deleted file mode 100644
index 7034c07551c..00000000000
--- a/community/lua-http/lpeg_patterns-0.5.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From d5d948bbecf5b88ebb099d95a6fae111ffe13bab Mon Sep 17 00:00:00 2001
-From: daurnimator <quae@daurnimator.com>
-Date: Sun, 15 Jul 2018 23:12:25 +1000
-Subject: [PATCH] http/request.lua: Use new lpeg_patterns 0.5 capture format
-
----
- README.md | 2 +-
- http-scm-0.rockspec | 2 +-
- http/request.lua | 2 +-
- 3 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/README.md b/README.md
-index a7183c3..91e2c6c 100644
---- a/README.md
-+++ b/README.md
-@@ -33,7 +33,7 @@ This will automatically install run-time lua dependencies for you.
- - [luaossl](http://25thandclement.com/~william/projects/luaossl.html) >= 20161208
- - [basexx](https://github.com/aiq/basexx/) >= 0.2.0
- - [lpeg](http://www.inf.puc-rio.br/~roberto/lpeg/lpeg.html)
-- - [lpeg_patterns](https://github.com/daurnimator/lpeg_patterns) >= 0.3
-+ - [lpeg_patterns](https://github.com/daurnimator/lpeg_patterns) >= 0.5
- - [fifo](https://github.com/daurnimator/fifo.lua)
-
- To use gzip compression you need **one** of:
-diff --git a/http/request.lua b/http/request.lua
-index aa80648..fccd843 100644
---- a/http/request.lua
-+++ b/http/request.lua
-@@ -36,7 +36,7 @@ local request_mt = {
- }
-
- local EOF = lpeg.P(-1)
--local sts_patt = lpeg.Cf(lpeg.Ct(true) * http_patts.Strict_Transport_Security, rawset) * EOF
-+local sts_patt = http_patts.Strict_Transport_Security * EOF
- local uri_patt = uri_patts.uri * EOF
- local uri_ref = uri_patts.uri_reference * EOF
-