aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-05-05 12:17:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-05-05 12:17:55 +0000
commitd2f849fcd6c925667b7dbde820ebc3298e31bffa (patch)
tree70ef0a1978cd8d7b395c5bf92ebbbca60c84a629
parenta9da172421ddb3db894e4cfcb89bdf21cc08df5d (diff)
community/aom: only disable neon on 32bit arm
no need to disable neon on aarch64 fixes #11476
-rw-r--r--community/aom/APKBUILD14
-rw-r--r--community/aom/force-disable-neon.patch20
2 files changed, 8 insertions, 26 deletions
diff --git a/community/aom/APKBUILD b/community/aom/APKBUILD
index cde56c90322..65b661b3752 100644
--- a/community/aom/APKBUILD
+++ b/community/aom/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Oleg Titov <oleg.titov@gmail.com>
pkgname=aom
pkgver=1.0.0
-pkgrel=0
+pkgrel=1
pkgdesc="Alliance for Open Media (AOM) AV1 codec SDK"
url="https://aomedia.org/"
arch="all"
@@ -10,9 +10,7 @@ license="custom"
options="!check" # No test suite from upstream
makedepends="cmake perl python3 yasm"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="$pkgname-$pkgver.tar.gz::https://aomedia.googlesource.com/aom/+archive/v$pkgver-errata1-avif.tar.gz
- force-disable-neon.patch"
-#builddir="$srcdir/$pkgname-$pkgver"
+source="$pkgname-$pkgver.tar.gz::https://aomedia.googlesource.com/aom/+archive/v$pkgver-errata1-avif.tar.gz"
case "$CARCH" in
ppc64le) makedepends="$makedepends linux-headers" ;;
@@ -21,8 +19,13 @@ esac
build() {
mkdir -p aom_build
cd aom_build
+ local _neon_opt=
+ case "$CARCH" in
+ arm*) _neon_opt="-DENABLE_NEON=OFF";;
+ esac
cmake .. \
+ $_neon_opt \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
@@ -52,5 +55,4 @@ unpack() {
-C "$builddir" > /dev/null
}
-sha512sums="3dcd119b3bef33add39b2d43577ed4a08ea47f9a565bba7119e45f58c21d017457d10dad3fa7bd332a35483d71e4b2d2514ac9e3859f9d5fe5ea9ac9442bca32 aom-1.0.0.tar.gz
-f26b5bee6176647bd3e703ca79d2a1930f28a9cfe314efc51679804545b6b3febc88ec92c6dbb564f0f9d957b8935c04d9b9e1bf8b22348374fe326497cd10fc force-disable-neon.patch"
+sha512sums="ea5226a72c048ee460ee798083990cbed91341875bb2998263d67078c3317efbe523f71d6b8dae420cf6691216befa9117f73a90132b4f5b09ed0f470f658e06 aom-1.0.0.tar.gz"
diff --git a/community/aom/force-disable-neon.patch b/community/aom/force-disable-neon.patch
deleted file mode 100644
index f3d0ef10950..00000000000
--- a/community/aom/force-disable-neon.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/build/cmake/cpu.cmake b/build/cmake/cpu.cmake
-index ef2d755..31e1118 100644
---- a/build/cmake/cpu.cmake
-+++ b/build/cmake/cpu.cmake
-@@ -13,13 +13,8 @@ if("${AOM_TARGET_CPU}" MATCHES "^arm")
- set(ARCH_ARM 1)
- set(RTCD_ARCH_ARM "yes")
-
-- if(ENABLE_NEON)
-- set(HAVE_NEON 1)
-- set(RTCD_HAVE_NEON "yes")
-- else()
-- set(HAVE_NEON 0)
-- set(AOM_RTCD_FLAGS ${AOM_RTCD_FLAGS} --disable-neon)
-- endif()
-+ set(HAVE_NEON 0)
-+ set(AOM_RTCD_FLAGS ${AOM_RTCD_FLAGS} --disable-neon)
- elseif("${AOM_TARGET_CPU}" MATCHES "^mips")
- set(ARCH_MIPS 1)
- set(RTCD_ARCH_MIPS "yes")