aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-05-21 16:21:44 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-21 16:29:12 +0000
commitd3c2ab872a9bbfedfcec8c95901cde5a63a2cb89 (patch)
treeddcafb87ca0f3c9a5977dabc6a756cbaff7cc7e0
parent7bc76d340d2dbecde9655bea12353c5530901983 (diff)
community/firefox: build against system webp and enable cdp
cdp enables the remote debugging tools, which are useful when using FF in a docker container (or some other sort of environment where you want debugging info (e.g. the developer console), but can't access the FF instance itself). Also explicitly enable system ffi and pixman. FF was built against these implicitly previously, so this is just here to ensure it stays that way.
-rw-r--r--community/firefox/APKBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/community/firefox/APKBUILD b/community/firefox/APKBUILD
index 1b9c65ac8f2..f39ee098a3d 100644
--- a/community/firefox/APKBUILD
+++ b/community/firefox/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=firefox
pkgver=76.0.1
-pkgrel=0
+pkgrel=1
pkgdesc="Firefox web browser"
url="https://www.firefox.com/"
# Limited on:
@@ -53,6 +53,8 @@ makedepends="
yasm
zip
pulseaudio-dev
+ libffi-dev
+ libwebp-dev
"
source="https://ftp.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
@@ -215,7 +217,9 @@ build() {
$_rust_simd \
$_low_mem_flags \
--enable-hardening \
+ --enable-system-pixman \
--with-system-bz2 \
+ --with-system-ffi \
--with-system-icu \
--with-system-libevent \
--with-system-nspr \
@@ -223,9 +227,11 @@ build() {
--with-system-pixman \
--with-system-png \
--with-system-zlib \
+ --with-system-libvpx \
+ --with-system-webp \
--with-clang-path=/usr/bin/clang \
--with-libclang-path=/usr/lib \
- --with-system-libvpx
+ --enable-cdp
make
}