aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAriadne Conill <ariadne@dereferenced.org>2020-08-01 11:44:52 -0600
committerAriadne Conill <ariadne@dereferenced.org>2020-08-01 11:46:21 -0600
commitd543fe0d1e3b39396a8c05d6018a15860add3bf2 (patch)
tree4ce483c2af19c96d36993b14fa789d6c7820249c
parent3134202fa1ba4f94fc29e2fcafb19002173eea02 (diff)
community/akonadi: increase thread stack size to 1MB
akonadiserver does a lot of recursion, combined with C++ can result in easily blasting through 80KB stack when walking an e-mail thread
-rw-r--r--community/akonadi/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/community/akonadi/APKBUILD b/community/akonadi/APKBUILD
index 33cf083a2fd..4cd7521f13c 100644
--- a/community/akonadi/APKBUILD
+++ b/community/akonadi/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=akonadi
pkgver=20.04.3
-pkgrel=0
+pkgrel=1
pkgdesc="A cross-desktop storage service for PIM data and meta data providing concurrent read, write, and query access"
arch="all !armhf"
url="https://community.kde.org/KDE_PIM"
@@ -15,6 +15,8 @@ source="https://download.kde.org/stable/release-service/$pkgver/src/akonadi-$pkg
subpackages="$pkgname-dev $pkgname-lang $pkgname-dbg"
build() {
+ # akonadi recurses while walking e-mail threads, so give it a decent stack
+ LDFLAGS="$LDFLAGS -Wl,-z,stack-size=1024768" \
cmake -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \