aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Diego Alegandro Diaz Urbaneja <sodomon2@gmail.com>2020-01-31 02:31:04 -0400
committerRasmus Thomsen <oss@cogitri.dev>2020-01-31 21:32:55 +0100
commitd6358b30f8c462da588d281d3e615f18f6e1ca33 (patch)
tree7e0cd1a2a2c5fef937abc4a36c3011950b08f9d0
parent50bcf01e59037ed43622fa04475ff6aeb34021eb (diff)
testing/dhewm3: new aport
Doom 3 engine with native 64-bit support, SDL, and OpenAL https://dhewm3.org/
-rw-r--r--testing/dhewm3/APKBUILD38
-rw-r--r--testing/dhewm3/dhewm3.desktop7
-rw-r--r--testing/dhewm3/dhewm3.pngbin0 -> 23573 bytes
-rw-r--r--testing/dhewm3/fix-musl.patch31
4 files changed, 76 insertions, 0 deletions
diff --git a/testing/dhewm3/APKBUILD b/testing/dhewm3/APKBUILD
new file mode 100644
index 00000000000..82e96cede2f
--- /dev/null
+++ b/testing/dhewm3/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Díaz Urbaneja Diego <sodomon2@gmail.com>
+# Maintainer: Díaz Urbaneja Diego <sodomon2@gmail.com>
+pkgname=dhewm3
+pkgver=1.5.1_rc1
+_realver=1.5.1_PRE1
+pkgrel=0
+pkgdesc="Doom 3 engine with native 64-bit support, SDL, and OpenAL"
+url="https://dhewm3.org/"
+arch="x86_64 x86" #disabled for the other architectures due to compiling problems
+license="GPL-3.0-only"
+depends="curl libjpeg-turbo libvorbis sdl2 zlib libogg libpng libvorbis"
+makedepends="openal-soft-dev make cmake sdl2-dev zlib-dev libjpeg-turbo-dev libogg-dev libpng-dev libvorbis-dev"
+options="!check" # make check not implemented
+source="$pkgname-$_realver.tar.gz::https://github.com/dhewm/dhewm3/archive/$_realver.tar.gz
+ fix-musl.patch
+ dhewm3.desktop
+ dhewm3.png"
+builddir="$srcdir/$pkgname-$_realver/neo"
+
+build() {
+ cmake CMakeLists.txt \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DD3XP=1 \
+ -DDEDICATED=1 .
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" libdir="$pkgdir/usr/lib" install
+ install -Dm644 "$srcdir"/dhewm3.desktop "$pkgdir/usr/share/applications/dhewm3.desktop"
+ install -Dm644 "$srcdir"/dhewm3.png "$pkgdir/usr/share/pixmaps/dhewm3.png"
+}
+
+sha512sums="73b2c43e16a82bc1a4fd6646493e7c69049a3c3abaac2206436f10d6180d616ad38c2c3480538e2690654c2cb73ec1be47d312939d64fd92ce03aff7fe64ceba dhewm3-1.5.1_PRE1.tar.gz
+396b1b4fe1889abf14141887e4a490b6069234784fd934ee120c68bf868febf767cf900a59871453ebd3adf62bf74bc7fba2bf5169b4594b6e735e0888930566 fix-musl.patch
+377d34c4d9ab21b09a501431e1bf8d123d3655a47499a7664db85168e2f85b73c8792bc958026593299eac57449f813b10047beb302784cc53d096e1cc37efbd dhewm3.desktop
+13f7a50d1f57d35bf582c3d99ff4dea4b18e60827f62aa640b7b43d419a3f4f478b45311d2abacfd2aa2f033c59f5c6253aa4916fc234b41eb6cc70d5eeac17c dhewm3.png"
diff --git a/testing/dhewm3/dhewm3.desktop b/testing/dhewm3/dhewm3.desktop
new file mode 100644
index 00000000000..b23e79d7b6a
--- /dev/null
+++ b/testing/dhewm3/dhewm3.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Dhewm3
+Exec=dhewm3
+Icon=dhewm3
+Type=Application
+Comment=A Doom 3 port
+Categories=Game;ActionGame; \ No newline at end of file
diff --git a/testing/dhewm3/dhewm3.png b/testing/dhewm3/dhewm3.png
new file mode 100644
index 00000000000..69ac661a806
--- /dev/null
+++ b/testing/dhewm3/dhewm3.png
Binary files differ
diff --git a/testing/dhewm3/fix-musl.patch b/testing/dhewm3/fix-musl.patch
new file mode 100644
index 00000000000..f4b33eb0c52
--- /dev/null
+++ b/testing/dhewm3/fix-musl.patch
@@ -0,0 +1,31 @@
+--- a/sys/posix/posix_main.cpp
++++ b/sys/posix/posix_main.cpp
+@@ -362,7 +362,7 @@
+ static const int crashSigs[] = { SIGILL, SIGABRT, SIGFPE, SIGSEGV };
+ static const char* crashSigNames[] = { "SIGILL", "SIGABRT", "SIGFPE", "SIGSEGV" };
+
+-#if defined(__linux__) || defined(__FreeBSD__) || defined(__APPLE__)
++#if ( defined(__linux__) && defined(__GLIBC__) ) || defined(__FreeBSD__) || defined(__APPLE__)
+ // TODO: https://github.com/ianlancetaylor/libbacktrace looks interesting and also supports windows apparently
+ #define D3_HAVE_BACKTRACE
+ #include <execinfo.h>
+--- a/sys/posix/posix_net.cpp
++++ b/sys/posix/posix_net.cpp
+@@ -644,7 +644,7 @@
+ return -1;
+ }
+
+-#if defined(_GNU_SOURCE)
++#if defined(_GNU_SOURCE) && defined(TEMP_FAILURE_RETRY)
+ // handle EINTR interrupted system call with TEMP_FAILURE_RETRY - this is probably GNU libc specific
+ if ( ( nbytes = TEMP_FAILURE_RETRY( read( fd, data, size ) ) ) == -1 ) {
+ #else
+@@ -701,7 +701,7 @@
+ return -1;
+ }
+
+-#if defined(_GNU_SOURCE)
++#if defined(_GNU_SOURCE) && defined(TEMP_FAILURE_RETRY)
+ // handle EINTR interrupted system call with TEMP_FAILURE_RETRY - this is probably GNU libc specific
+ if ( ( nbytes = TEMP_FAILURE_RETRY ( write( fd, data, size ) ) ) == -1 ) {
+ #else