aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoromni <omni@gitlab.alpinelinux.org>2021-02-07 10:04:33 +0000
committerMilan P. Stanić <mps@arvanta.net>2021-02-07 16:38:57 +0000
commitd78a05177f013c6be5873d1dfe3f97ffdfe79140 (patch)
tree11e417e9784cd76e6f4ebadb2b73fe0ac7923fcc
parentdcd28673964ee82e62b869e84cdcc7265ccebe8a (diff)
testing/termshark: new aport
-rw-r--r--testing/termshark/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/termshark/APKBUILD b/testing/termshark/APKBUILD
new file mode 100644
index 00000000000..a18b25f908c
--- /dev/null
+++ b/testing/termshark/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: omni <omni@gitlab.alpinelinux.org>
+# Maintainer:
+
+pkgname=termshark
+pkgver=2.2.0
+pkgrel=0
+pkgdesc="terminal UI for tshark, inspired by Wireshark"
+arch="all"
+url="https://termshark.io"
+license="MIT"
+depends="tshark"
+makedepends="go"
+source="$pkgname-$pkgver.tar.gz::https://github.com/gcla/termshark/archive/v$pkgver.tar.gz"
+
+export GOPATH="$srcdir"
+export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
+
+build() {
+ go build -v ./cmd/...
+}
+
+check() {
+ go test -v ./...
+}
+
+package() {
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 docs/UserGuide.md -t "$pkgdir"/usr/share/doc/$pkgname
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
+
+ # Help clean-up as some paths are readonly
+ rm -rf "$GOPATH"/pkg/mod
+}
+
+sha512sums="5ab2e2ccb7d4ab71a5b364c9677a24725dc5702a1c574f93ec2f4f09aba2322c292728f9ea02eb1d7378e7ea32ee4952dc59fd7b699e70fcaa3007c1f28219db termshark-2.2.0.tar.gz"