aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2020-11-21 22:48:20 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-11-23 01:54:04 +0000
commite373da857ad943702e87e9fa59b5df4fc3bf4a2a (patch)
tree446b74091a83c473a58af6905056a6fc804bfe1d
parent4b34b050385d75fc268f274b228dc208d0c2e60d (diff)
testing/py3-qtgraph: new aport
Scientific Graphics and GUI Library for Python http://www.pyqtgraph.org
-rw-r--r--testing/py3-qtgraph/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-qtgraph/APKBUILD b/testing/py3-qtgraph/APKBUILD
new file mode 100644
index 00000000000..3d81e32c952
--- /dev/null
+++ b/testing/py3-qtgraph/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=py3-qtgraph
+pkgver=0.11.0
+pkgrel=0
+pkgdesc="Scientific Graphics and GUI Library for Python"
+url="http://www.pyqtgraph.org/"
+arch="noarch"
+license="MIT"
+depends="python3 py3-qt5 py3-numpy py3-scipy py3-opengl"
+checkdepends="py3-pytest xvfb-run"
+source="$pkgname-$pkgver.tar.gz::https://github.com/pyqtgraph/pyqtgraph/archive/pyqtgraph-$pkgver.tar.gz"
+builddir="$srcdir/pyqtgraph-pyqtgraph-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ xvfb-run python3 test.py
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="1ef7c3c28359a25861424cf7670dcfe471ba62786ebb0288af72a3f626af49ca51a87ac85fccacb7cadce49b6318efb895a7682fb93aa84ff9e2171134d8071b py3-qtgraph-0.11.0.tar.gz"