aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-11-11 18:34:09 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-20 10:40:10 +0100
commite3cc6f649ff9d9a8e2dda94379dd15e2d76ba0ee (patch)
tree6d370409d75b930c2055ffa6522e64a7666d5d8c
parent3963be7a182c0a20ff4a5fe8fb23097d4c1ed31c (diff)
main/fcgi: upgrade to 2.4.2
-rw-r--r--main/fcgi/20-fcgi-2.4.0-clientdata-pointer.patch96
-rw-r--r--main/fcgi/30-fcgi-2.4.0-html-updates.patch65
-rw-r--r--main/fcgi/APKBUILD42
-rw-r--r--main/fcgi/CVE-2012-6687.patch86
-rw-r--r--main/fcgi/configure.patch28
-rw-r--r--main/fcgi/fcgi-2.4.0-Makefile.am-CPPFLAGS.patch36
-rw-r--r--main/fcgi/fcgi-2.4.0-gcc44_fixes.patch11
7 files changed, 10 insertions, 354 deletions
diff --git a/main/fcgi/20-fcgi-2.4.0-clientdata-pointer.patch b/main/fcgi/20-fcgi-2.4.0-clientdata-pointer.patch
deleted file mode 100644
index ba4793765d5..00000000000
--- a/main/fcgi/20-fcgi-2.4.0-clientdata-pointer.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-Index: fcgi-2.4.0/cgi-fcgi/cgi-fcgi.c
-===================================================================
---- fcgi-2.4.0.orig/cgi-fcgi/cgi-fcgi.c
-+++ fcgi-2.4.0/cgi-fcgi/cgi-fcgi.c
-@@ -21,6 +21,7 @@ static const char rcsid[] = "$Id: cgi-fc
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
-+#include <sys/types.h>
-
- #include "fcgi_config.h"
-
-@@ -145,7 +146,7 @@ static FCGI_BeginRequestBody MakeBeginRe
-
-
- static int bytesToRead; /* number of bytes to read from Web Server */
--static int appServerSock = -1; /* Socket connected to FastCGI application,
-+static size_t appServerSock = -1; /* Socket connected to FastCGI application,
- * used by AppServerReadHandler and
- * AppServerWriteHandler. */
- static Buffer fromAS; /* Bytes read from the FCGI application server. */
-@@ -640,7 +641,7 @@ static int ParseArgs(int argc, char *arg
- }
- if((av[ac] = (char *)malloc(strlen(tp1)+1)) == NULL) {
- fprintf(stderr, "Cannot allocate %d bytes\n",
-- strlen(tp1)+1);
-+ (int)strlen(tp1)+1);
- exit(-1);
- }
- strcpy(av[ac++], tp1);
-Index: fcgi-2.4.0/examples/threaded.c
-===================================================================
---- fcgi-2.4.0.orig/examples/threaded.c
-+++ fcgi-2.4.0/examples/threaded.c
-@@ -24,7 +24,7 @@ static int counts[THREAD_COUNT];
-
- static void *doit(void *a)
- {
-- int rc, i, thread_id = (int)a;
-+ size_t rc, i, thread_id = (size_t)a;
- pid_t pid = getpid();
- FCGX_Request request;
- char *server_name;
-@@ -53,7 +53,7 @@ static void *doit(void *a)
- "<h1>FastCGI Hello! (multi-threaded C, fcgiapp library)</h1>"
- "Thread %d, Process %ld<p>"
- "Request counts for %d threads running on host <i>%s</i><p><code>",
-- thread_id, pid, THREAD_COUNT, server_name ? server_name : "?");
-+ (int)thread_id, pid, THREAD_COUNT, server_name ? server_name : "?");
-
- sleep(2);
-
-@@ -71,7 +71,7 @@ static void *doit(void *a)
-
- int main(void)
- {
-- int i;
-+ size_t i;
- pthread_t id[THREAD_COUNT];
-
- FCGX_Init();
-Index: fcgi-2.4.0/include/fcgios.h
-===================================================================
---- fcgi-2.4.0.orig/include/fcgios.h
-+++ fcgi-2.4.0/include/fcgios.h
-@@ -93,7 +93,7 @@ extern "C" {
- # if defined(__STDC__) || defined(__cplusplus)
- typedef void *ClientData;
- # else
-- typedef int *ClientData;
-+ typedef size_t *ClientData;
- # endif /* __STDC__ */
- #define _CLIENTDATA
- #endif
-Index: fcgi-2.4.0/libfcgi/os_unix.c
-===================================================================
---- fcgi-2.4.0.orig/libfcgi/os_unix.c
-+++ fcgi-2.4.0/libfcgi/os_unix.c
-@@ -1155,7 +1155,7 @@ int OS_Accept(int listen_sock, int fail_
-
- for (;;) {
- do {
--#ifdef HAVE_SOCKLEN
-+#ifdef HAVE_SYS_SOCKET_H
- socklen_t len = sizeof(sa);
- #else
- int len = sizeof(sa);
-@@ -1255,7 +1255,7 @@ int OS_IsFcgi(int sock)
- struct sockaddr_in in;
- struct sockaddr_un un;
- } sa;
--#ifdef HAVE_SOCKLEN
-+#ifdef HAVE_SYS_SOCKET_H
- socklen_t len = sizeof(sa);
- #else
- int len = sizeof(sa);
diff --git a/main/fcgi/30-fcgi-2.4.0-html-updates.patch b/main/fcgi/30-fcgi-2.4.0-html-updates.patch
deleted file mode 100644
index ca10a6a6039..00000000000
--- a/main/fcgi/30-fcgi-2.4.0-html-updates.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-Index: fcgi-2.4.0/doc/fcgi-devel-kit.htm
-===================================================================
---- fcgi-2.4.0.orig/doc/fcgi-devel-kit.htm
-+++ fcgi-2.4.0/doc/fcgi-devel-kit.htm
-@@ -19,7 +19,7 @@
- </HEAD>
- <BODY>
- <P CLASS="c1">
-- <IMG BORDER="0" SRC="../images/fcgi-hd.gif" ALT="[[FastCGI]]"><BR CLEAR="all">
-+ <IMG BORDER="0" SRC="images/fcgi-hd.gif" ALT="[[FastCGI]]"><BR CLEAR="all">
- </P>
- <H3 CLASS="c2">
- FastCGI Developer&#39;s Kit
-Index: fcgi-2.4.0/doc/fcgi-java.htm
-===================================================================
---- fcgi-2.4.0.orig/doc/fcgi-java.htm
-+++ fcgi-2.4.0/doc/fcgi-java.htm
-@@ -20,7 +20,7 @@
- </HEAD>
- <BODY>
- <DIV CLASS="c1">
-- <A HREF="http://fastcgi.com"><IMG BORDER="0" SRC="../images/fcgi-hd.gif" ALT="[[FastCGI]]"></A>
-+ <A HREF="http://fastcgi.com"><IMG BORDER="0" SRC="images/fcgi-hd.gif" ALT="[[FastCGI]]"></A>
- </DIV>
- <BR CLEAR="all">
- <DIV CLASS="c1">
-Index: fcgi-2.4.0/doc/fcgi-perf.htm
-===================================================================
---- fcgi-2.4.0.orig/doc/fcgi-perf.htm
-+++ fcgi-2.4.0/doc/fcgi-perf.htm
-@@ -19,7 +19,7 @@
- </HEAD>
- <BODY>
- <DIV CLASS="c1">
-- <A HREF="http://fastcgi.com"><IMG BORDER="0" SRC="../images/fcgi-hd.gif" ALT="[[FastCGI]]"></A>
-+ <A HREF="http://fastcgi.com"><IMG BORDER="0" SRC="images/fcgi-hd.gif" ALT="[[FastCGI]]"></A>
- </DIV>
- <BR CLEAR="all">
- <DIV CLASS="c1">
-Index: fcgi-2.4.0/doc/fcgi-perl.htm
-===================================================================
---- fcgi-2.4.0.orig/doc/fcgi-perl.htm
-+++ fcgi-2.4.0/doc/fcgi-perl.htm
-@@ -19,7 +19,7 @@
- </HEAD>
- <BODY>
- <DIV CLASS="c1">
-- <A HREF="http://fastcgi.com"><IMG BORDER="0" SRC="../images/fcgi-hd.gif" ALT="[[FastCGI]]"></A>
-+ <A HREF="http://fastcgi.com"><IMG BORDER="0" SRC="images/fcgi-hd.gif" ALT="[[FastCGI]]"></A>
- </DIV>
- <BR CLEAR="all">
-
-Index: fcgi-2.4.0/doc/fcgi-tcl.htm
-===================================================================
---- fcgi-2.4.0.orig/doc/fcgi-tcl.htm
-+++ fcgi-2.4.0/doc/fcgi-tcl.htm
-@@ -19,7 +19,7 @@
- </HEAD>
- <BODY>
- <DIV CLASS="c1">
-- <A HREF="http://fastcgi.com"><IMG BORDER="0" SRC="../images/fcgi-hd.gif" ALT="[[FastCGI]]"></A>
-+ <A HREF="http://fastcgi.com"><IMG BORDER="0" SRC="images/fcgi-hd.gif" ALT="[[FastCGI]]"></A>
- </DIV>
- <BR CLEAR="all">
- <DIV CLASS="c1">
diff --git a/main/fcgi/APKBUILD b/main/fcgi/APKBUILD
index adee7984e4a..f579b0627c5 100644
--- a/main/fcgi/APKBUILD
+++ b/main/fcgi/APKBUILD
@@ -1,37 +1,24 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=fcgi
-pkgver=2.4.0
-pkgrel=8
+_pkgname=fcgi2
+pkgver=2.4.2
+pkgrel=0
pkgdesc="FAST CGI(fcgi) is a language independent, high performant extension to CGI"
-url="http://www.fastcgi.com"
+url="https://github.com/FastCGI-Archives/fcgi2"
arch="all"
-license="GPL"
-depends=""
+license="custom"
+options="!check" # no test suite
makedepends="libtool autoconf automake"
subpackages="$pkgname-dev $pkgname++:xx"
-source="https://distfiles.alpinelinux.org/distfiles/$pkgname-$pkgver.tar.gz
- configure.patch
- fcgi-2.4.0-gcc44_fixes.patch
- fcgi-2.4.0-Makefile.am-CPPFLAGS.patch
- 20-fcgi-2.4.0-clientdata-pointer.patch
- 30-fcgi-2.4.0-html-updates.patch
- CVE-2012-6687.patch
- "
+source="$_pkgname-$pkgver.tar.gz::https://github.com/FastCGI-Archives/fcgi2/archive/$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- default_prepare
-
- sed -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.in
-
- libtoolize --force && aclocal && autoconf \
- && automake --force --add-missing
-}
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd $builddir
export LIBS="-lm"
+ ./autogen.sh
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -40,15 +27,12 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--enable-shared
- # work around parallel build issue
- make -C libfcgi libfcgi.la
make
}
package() {
cd $builddir
make DESTDIR="$pkgdir" install
-
}
xx() {
@@ -57,10 +41,4 @@ xx() {
mv "$pkgdir"/usr/lib/*++* "$subpkgdir"/usr/lib/
}
-sha512sums="38164d11112e834b30c6f809da4e184021e8d22ec8db2c49ad827895a75b99dc1824b94831304aa0ae1174176fe64d02a12882b1a00b780119600bdc39a90927 fcgi-2.4.0.tar.gz
-57ae87e526c6fbc39b81b93b0fa2d159315f4d06f9a58053a5636bb3377955c3d92024f2363af483bf4c22b7f3c888d1f1505e265f77e8a1b690740cf5909959 configure.patch
-6dafc960c30c1c9f5e09eff0fa71a0202265e063b9ccc56b82d58961f4a2e290734dcea06bd45ea58abc5a394db6edbaed4ccac5dc1fcfa22f0595917fa24243 fcgi-2.4.0-gcc44_fixes.patch
-04886b4aa5fab4aca7ef8834b73c1b8d899fcfd8072934a9b337913306335e53e5b24069af6c7e7ac37272bb6bbd9fe0eb82704255a58c344fb964846f925255 fcgi-2.4.0-Makefile.am-CPPFLAGS.patch
-c5339ae940994daeec4cf8030933ca2ab5a00651b91eb5d2ff3b871673b5a62646bfb8e81c190ad6d83015fcf59df4076bc745f097ddcada220ca0dc4a05db6a 20-fcgi-2.4.0-clientdata-pointer.patch
-79abe9f43150b3163e92030cc9afbee90f69f04bd487254d187abda6fa3484623f605394c96eeb6fd4203d2b06f7e771c9b46f9c21b03cde1aa043da9b3e8d5e 30-fcgi-2.4.0-html-updates.patch
-119cc765d330d7324c1a8aeb87492d270ee43b23e3d2036445b6f494e2fe8031093fbc0af78b137588c28ecddde2e85ff932a851840896e105efc14403e05a68 CVE-2012-6687.patch"
+sha512sums="03aca9899eacfd54c878b30691cc4f8db957a065b46426d764003fd057cbf24b4e12ddd26c9b980d5d8965ca40831e415d330e9830529c0d4153400b5c2c8c02 fcgi2-2.4.2.tar.gz"
diff --git a/main/fcgi/CVE-2012-6687.patch b/main/fcgi/CVE-2012-6687.patch
deleted file mode 100644
index d4bc2400e20..00000000000
--- a/main/fcgi/CVE-2012-6687.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-Author: Anton Kortunov <toshic.toshic@gmail.com>
-Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/libfcgi/+bug/933417
-Description: use poll in os_unix.c instead of select to avoid problem with > 1024 connections
-Forwarded: yes, fastcgi-developers@mailman.fastcgi.com
-
-diff --git a/libfcgi/os_unix.c b/libfcgi/os_unix.c
-index 73e6a7f..af35aee 100755
---- a/libfcgi/os_unix.c
-+++ b/libfcgi/os_unix.c
-@@ -42,6 +42,7 @@ static const char rcsid[] = "$Id: os_unix.c,v 1.37 2002/03/05 19:14:49 robs Exp
- #include <sys/time.h>
- #include <sys/un.h>
- #include <signal.h>
-+#include <poll.h>
-
- #ifdef HAVE_NETDB_H
- #include <netdb.h>
-@@ -103,6 +104,9 @@ static int volatile maxFd = -1;
- static int shutdownPending = FALSE;
- static int shutdownNow = FALSE;
-
-+static int libfcgiOsClosePollTimeout = 2000;
-+static int libfcgiIsAfUnixKeeperPollTimeout = 2000;
-+
- void OS_ShutdownPending()
- {
- shutdownPending = TRUE;
-@@ -168,6 +172,16 @@ int OS_LibInit(int stdioFds[3])
- if(libInitialized)
- return 0;
-
-+ char *libfcgiOsClosePollTimeoutStr = getenv( "LIBFCGI_OS_CLOSE_POLL_TIMEOUT" );
-+ if(libfcgiOsClosePollTimeoutStr) {
-+ libfcgiOsClosePollTimeout = atoi(libfcgiOsClosePollTimeoutStr);
-+ }
-+
-+ char *libfcgiIsAfUnixKeeperPollTimeoutStr = getenv( "LIBFCGI_IS_AF_UNIX_KEEPER_POLL_TIMEOUT" );
-+ if(libfcgiIsAfUnixKeeperPollTimeoutStr) {
-+ libfcgiIsAfUnixKeeperPollTimeout = atoi(libfcgiIsAfUnixKeeperPollTimeoutStr);
-+ }
-+
- asyncIoTable = (AioInfo *)malloc(asyncIoTableSize * sizeof(AioInfo));
- if(asyncIoTable == NULL) {
- errno = ENOMEM;
-@@ -755,19 +769,16 @@ int OS_Close(int fd)
-
- if (shutdown(fd, 1) == 0)
- {
-- struct timeval tv;
-- fd_set rfds;
-+ struct pollfd pfd;
- int rv;
- char trash[1024];
-
-- FD_ZERO(&rfds);
-+ pfd.fd = fd;
-+ pfd.events = POLLIN;
-
- do
- {
-- FD_SET(fd, &rfds);
-- tv.tv_sec = 2;
-- tv.tv_usec = 0;
-- rv = select(fd + 1, &rfds, NULL, NULL, &tv);
-+ rv = poll(&pfd, 1, libfcgiOsClosePollTimeout);
- }
- while (rv > 0 && read(fd, trash, sizeof(trash)) > 0);
- }
-@@ -1116,13 +1127,11 @@ static int is_reasonable_accept_errno (const int error)
- */
- static int is_af_unix_keeper(const int fd)
- {
-- struct timeval tval = { READABLE_UNIX_FD_DROP_DEAD_TIMEVAL };
-- fd_set read_fds;
--
-- FD_ZERO(&read_fds);
-- FD_SET(fd, &read_fds);
-+ struct pollfd pfd;
-+ pfd.fd = fd;
-+ pfd.events = POLLIN;
-
-- return select(fd + 1, &read_fds, NULL, NULL, &tval) >= 0 && FD_ISSET(fd, &read_fds);
-+ return poll(&pfd, 1, libfcgiIsAfUnixKeeperPollTimeout) >= 0 && (pfd.revents & POLLIN);
- }
-
- /*
diff --git a/main/fcgi/configure.patch b/main/fcgi/configure.patch
deleted file mode 100644
index 8ea19fb50c6..00000000000
--- a/main/fcgi/configure.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/configure.in b/configure.in
-index e1941d0..4780394 100755
---- a/configure.in
-+++ b/configure.in
-@@ -4,10 +4,12 @@ dnl This file is an input file used by the GNU "autoconf" program to
- dnl generate the file "configure", which is run during the build
- dnl to configure the system for the local environment.
-
--AC_INIT
--AM_INIT_AUTOMAKE(fcgi, 2.4.0)
-+AC_INIT(fcgi, 2.4.0)
-+AM_INIT_AUTOMAKE(1.9 foreign)
-
--AM_CONFIG_HEADER(fcgi_config.h)
-+AC_CONFIG_HEADERS(fcgi_config.h)
-+
-+AM_MAINTAINER_MODE
-
- AC_PROG_CC
- AC_PROG_CPP
-@@ -47,6 +49,7 @@ AC_LANG([C])
-
- AC_CHECK_LIB([nsl], [gethostbyname])
- AC_CHECK_LIB([socket], [socket])
-+AC_SEARCH_LIBS(frexp, [m], [], [AC_MSG_ERROR([unable to find the frexp()]) ])
-
- ACX_PTHREAD([THREADED=threaded${EXEEXT}])
- AC_SUBST([THREADED])
diff --git a/main/fcgi/fcgi-2.4.0-Makefile.am-CPPFLAGS.patch b/main/fcgi/fcgi-2.4.0-Makefile.am-CPPFLAGS.patch
deleted file mode 100644
index 7dfe0f98fa1..00000000000
--- a/main/fcgi/fcgi-2.4.0-Makefile.am-CPPFLAGS.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -ru fcgi-2.4.0-orig/cgi-fcgi/Makefile.am fcgi-2.4.0/cgi-fcgi/Makefile.am
---- fcgi-2.4.0-orig/cgi-fcgi/Makefile.am 2007-03-05 18:09:31.000000000 +0100
-+++ fcgi-2.4.0/cgi-fcgi/Makefile.am 2007-03-05 19:38:14.000000000 +0100
-@@ -2,7 +2,7 @@
- bin_PROGRAMS = cgi-fcgi
-
- INCLUDEDIR = ../include
--CPPFLAGS = @CPPFLAGS@ -I$(top_srcdir)/include
-+AM_CPPFLAGS = @CPPFLAGS@ -I$(top_srcdir)/include
-
- INCLUDE_FILES = $(INCLUDEDIR)/fastcgi.h \
- $(INCLUDEDIR)/fcgiapp.h \
-diff -ru fcgi-2.4.0-orig/examples/Makefile.am fcgi-2.4.0/examples/Makefile.am
---- fcgi-2.4.0-orig/examples/Makefile.am 2007-03-05 18:09:31.000000000 +0100
-+++ fcgi-2.4.0/examples/Makefile.am 2007-03-05 19:38:34.000000000 +0100
-@@ -11,7 +11,7 @@
- EXTRA_PROGRAMS = threaded echo-cpp
-
- INCLUDEDIR = ../include
--CPPFLAGS = @CPPFLAGS@ -I$(top_srcdir)/include
-+AM_CPPFLAGS = @CPPFLAGS@ -I$(top_srcdir)/include
-
- INCLUDE_FILES = $(INCLUDEDIR)/fastcgi.h \
- $(INCLUDEDIR)/fcgiapp.h \
-diff -ru fcgi-2.4.0-orig/libfcgi/Makefile.am fcgi-2.4.0/libfcgi/Makefile.am
---- fcgi-2.4.0-orig/libfcgi/Makefile.am 2007-03-05 18:09:31.000000000 +0100
-+++ fcgi-2.4.0/libfcgi/Makefile.am 2007-03-05 19:38:03.000000000 +0100
-@@ -1,7 +1,7 @@
- # $Id: fcgi-2.4.0-Makefile.am-CPPFLAGS.patch,v 1.1 2007/06/28 23:15:26 till Exp $
-
- INCLUDEDIR = ../include
--CPPFLAGS = @CPPFLAGS@ -I$(top_srcdir)/include
-+AM_CPPFLAGS = @CPPFLAGS@ -I$(top_srcdir)/include
-
- INCLUDE_FILES = $(INCLUDEDIR)/fastcgi.h \
- $(INCLUDEDIR)/fcgiapp.h \
diff --git a/main/fcgi/fcgi-2.4.0-gcc44_fixes.patch b/main/fcgi/fcgi-2.4.0-gcc44_fixes.patch
deleted file mode 100644
index 6c5cfe2f981..00000000000
--- a/main/fcgi/fcgi-2.4.0-gcc44_fixes.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -up fcgi-2.4.0/libfcgi/fcgio.cpp.gcc44_fixes fcgi-2.4.0/libfcgi/fcgio.cpp
---- fcgi-2.4.0/libfcgi/fcgio.cpp.gcc44_fixes 2002-02-24 21:12:22.000000000 +0100
-+++ fcgi-2.4.0/libfcgi/fcgio.cpp 2009-02-15 11:35:18.000000000 +0100
-@@ -23,6 +23,7 @@
- #endif
-
- #include <limits.h>
-+#include <cstdio>
- #include "fcgio.h"
-
- using std::streambuf;