aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCormac Stephenson <c7s@kasku.net>2021-03-29 22:24:33 +0000
committerLeo <thinkabit.ukim@gmail.com>2021-03-30 02:02:43 +0000
commite56dac3083346c610c63e176b1812af9fb7f375c (patch)
tree80b36999f53dfd706559ac62425b78768b9dcb05
parent5ee864961e8c60b0abac9321e42c34ea42cb72fb (diff)
testing/libhangul: new aport
Co-authored-by: Leo <thinkabit.ukim@gmail.com>
-rw-r--r--testing/libhangul/APKBUILD40
-rw-r--r--testing/libhangul/fix-gettext-version.patch13
2 files changed, 53 insertions, 0 deletions
diff --git a/testing/libhangul/APKBUILD b/testing/libhangul/APKBUILD
new file mode 100644
index 00000000000..922db379500
--- /dev/null
+++ b/testing/libhangul/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Contributor: Cormac Stephenson <c7s@kasku.net>
+# Maintainer: Cormac Stephenson <c7s@kasku.net>
+pkgname=libhangul
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Library for Korean input method logic"
+url="https://github.com/libhangul/libhangul"
+arch="all"
+license="LGPL-2.1-only"
+makedepends="automake autoconf libtool gettext-dev"
+subpackages="$pkgname-dev $pkgname-lang"
+source="https://github.com/libhangul/libhangul/archive/refs/tags/libhangul-$pkgver.tar.gz
+ fix-gettext-version.patch
+ "
+builddir="$srcdir/libhangul-libhangul-$pkgver"
+
+prepare() {
+ default_prepare
+ ./autogen.sh
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="f601c18de0f29e8826373c77a7b96938a0a54b8b10a14c4daebf2a93d6fc567edc470608f1573853e28db1f9d7a6c66debdbf6dff0262f9d69d4af7ed730f611 libhangul-0.1.0.tar.gz
+8d41a76c4c186068551ebeb5bbab983e43435178dcd516279d16a7a03648f45fecf3fe9792e061c4b6f0f5bb2791776c7d6c6608dc9e7035e4a48110a4ef1890 fix-gettext-version.patch"
diff --git a/testing/libhangul/fix-gettext-version.patch b/testing/libhangul/fix-gettext-version.patch
new file mode 100644
index 00000000000..cf97cc1270e
--- /dev/null
+++ b/testing/libhangul/fix-gettext-version.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 8b389be..16a44d8 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -49,7 +49,7 @@ GETTEXT_PACKAGE="$PACKAGE"
+ AC_SUBST(GETTEXT_PACKAGE)
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", gettext package name)
+ AM_GNU_GETTEXT([external])
+-AM_GNU_GETTEXT_VERSION(0.18)
++AM_GNU_GETTEXT_VERSION(0.20)
+ AM_ICONV
+
+ # Checks for unit test framework