aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2017-11-30 05:11:01 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-30 08:53:31 +0000
commite635fe5794f79419e83076a73bfe5447cf3c730a (patch)
tree4a460ec802e92c44f9330fe59a31e269d84c9556
parentb71c2ae4be19a147fa924274376903c359bee14a (diff)
main/opusfile: upgrade to 0.10; modernize
-rw-r--r--main/opusfile/APKBUILD30
-rw-r--r--main/opusfile/libressl.patch51
2 files changed, 60 insertions, 21 deletions
diff --git a/main/opusfile/APKBUILD b/main/opusfile/APKBUILD
index 1185dd056e2..3ec7987abd5 100644
--- a/main/opusfile/APKBUILD
+++ b/main/opusfile/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=opusfile
-pkgver=0.8
-pkgrel=3
+pkgver=0.10
+pkgrel=0
pkgdesc="A high-level API for decoding and seeking within .opus files"
url="http://www.opus-codec.org/"
arch="all"
@@ -14,10 +14,11 @@ subpackages="$pkgname-dev $pkgname-doc"
source="http://downloads.xiph.org/releases/opus/$pkgname-$pkgver.tar.gz
libressl.patch
"
-
builddir="$srcdir"/$pkgname-$pkgver
+
build() {
cd "$builddir"
+
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -26,19 +27,22 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
- --disable-static \
- || return 1
- make || return 1
+ --disable-static
+
+ make
+}
+
+check() {
+ cd "$builddir"
+
+ make check
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+
+ make DESTDIR="$pkgdir" install
}
-md5sums="78ad26f75900dc8428d75e6e4256196d opusfile-0.8.tar.gz
-2fea17f38577c79482b4fa500cc71497 libressl.patch"
-sha256sums="2c231ed3cfaa1b3173f52d740e5bbd77d51b9dfecb87014b404917fba4b855a4 opusfile-0.8.tar.gz
-b00620ae7355365fc198bc0d2b83b1d762bff120bc93c36350ab3a3f1a509bdf libressl.patch"
-sha512sums="4db553211ac52b9cd9c03449e602fb720d757df385b74e076ce3552a17ecf0e80c861c326fd2570b26f5ffc1c42dff781eef61c25d7a016116a021c9d2176bbb opusfile-0.8.tar.gz
-cf5e8c56dad2e56dcc9b5d1d655d8b1469ce0cd59a19593c20b98bdb1d843c9f98d5ac2c4b3a3836b93e5e9cc7807f4fa5e5430d69d6fb81a9bf2e33491e1f31 libressl.patch"
+sha512sums="302601c31ca28bff175cefa99ac16177122a786d043be229616e2c98b7ffaf4a96b8bb17ca16e31240325a92763f417315b54d8f1b2f4f63f445cb7ad43c4a37 opusfile-0.10.tar.gz
+4a5572bb0671e8bf38d70883d61257e182e4e417828c65461351649728ab5560c7da0d5d4560a30bbad256bfcafa874322a8f1470a796f4948af93d50dd4a74e libressl.patch"
diff --git a/main/opusfile/libressl.patch b/main/opusfile/libressl.patch
index a1bbf0b344c..ed68b0b3a1a 100644
--- a/main/opusfile/libressl.patch
+++ b/main/opusfile/libressl.patch
@@ -1,6 +1,7 @@
+# https://github.com/voidlinux/void-packages/master/srcpkgs/opusfile/patches/
--- a/src/http.c
+++ b/src/http.c
-@@ -1517,7 +1517,7 @@ static long op_bio_retry_ctrl(BIO *_b,int _cmd,long _num,void *_ptr){
+@@ -1530,7 +1530,7 @@
return ret;
}
@@ -8,8 +9,8 @@
+# if OPENSSL_VERSION_NUMBER<0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
# define BIO_set_data(_b,_ptr) ((_b)->ptr=(_ptr))
# define BIO_set_init(_b,_init) ((_b)->init=(_init))
- # endif
-@@ -1524,7 +1524,7 @@ static long op_bio_retry_ctrl(BIO *_b,int _cmd,long _num,void *_ptr){
+ # define ASN1_STRING_get0_data ASN1_STRING_data
+@@ -1538,7 +1538,7 @@
static int op_bio_retry_new(BIO *_b){
BIO_set_init(_b,1);
@@ -18,7 +19,7 @@
_b->num=0;
# endif
BIO_set_data(_b,NULL);
-@@ -1535,7 +1535,7 @@ static int op_bio_retry_free(BIO *_b){
+@@ -1549,7 +1549,7 @@
return _b!=NULL;
}
@@ -27,7 +28,7 @@
/*This is not const because OpenSSL doesn't allow it, even though it won't
write to it.*/
static BIO_METHOD op_bio_retry_method={
-@@ -1556,7 +1556,7 @@ static BIO_METHOD op_bio_retry_method={
+@@ -1570,7 +1570,7 @@
proxying https URL requests.*/
static int op_http_conn_establish_tunnel(OpusHTTPStream *_stream,
OpusHTTPConn *_conn,op_sock _fd,SSL *_ssl_conn,BIO *_ssl_bio){
@@ -36,7 +37,7 @@
BIO_METHOD *bio_retry_method;
# endif
BIO *retry_bio;
-@@ -1569,7 +1569,7 @@ static int op_http_conn_establish_tunnel(OpusHTTPStream *_stream,
+@@ -1583,7 +1583,7 @@
ret=op_http_conn_write_fully(_conn,
_stream->proxy_connect.buf,_stream->proxy_connect.nbuf);
if(OP_UNLIKELY(ret<0))return ret;
@@ -45,7 +46,7 @@
bio_retry_method=BIO_meth_new(BIO_TYPE_NULL,"retry");
if(bio_retry_method==NULL)return OP_EFAULT;
BIO_meth_set_write(bio_retry_method,op_bio_retry_write);
-@@ -1592,7 +1592,7 @@ static int op_http_conn_establish_tunnel(OpusHTTPStream *_stream,
+@@ -1606,7 +1606,7 @@
/*This shouldn't succeed, since we can't read yet.*/
OP_ALWAYS_TRUE(SSL_connect(_ssl_conn)<0);
SSL_set_bio(_ssl_conn,_ssl_bio,_ssl_bio);
@@ -54,7 +55,41 @@
BIO_meth_free(bio_retry_method);
# endif
/*Only now do we disable write coalescing, to allow the CONNECT
-@@ -2231,7 +2231,7 @@ static int op_http_stream_open(OpusHTTPStream *_stream,const char *_url,
+@@ -1635,7 +1635,7 @@
+ return NULL;
+ }
+
+-# if OPENSSL_VERSION_NUMBER<0x10002000L
++# if OPENSSL_VERSION_NUMBER<0x10002000L || defined(LIBRESSL_VERSION_NUMBER)
+ /*Match a host name against a host with a possible wildcard pattern according
+ to the rules of RFC 6125 Section 6.4.3.
+ Return: 0 if the pattern doesn't match, and a non-zero value if it does.*/
+@@ -1893,7 +1893,7 @@
+ SSL_set_tlsext_host_name(_ssl_conn,_stream->url.host);
+ # endif
+ skip_certificate_check=_stream->skip_certificate_check;
+-# if OPENSSL_VERSION_NUMBER>=0x10002000L
++# if OPENSSL_VERSION_NUMBER>=0x10002000L && !defined(LIBRESSL_VERSION_NUMBER)
+ /*As of version 1.0.2, OpenSSL can finally do hostname checks automatically.
+ Of course, they make it much more complicated than it needs to be.*/
+ if(!skip_certificate_check){
+@@ -1956,13 +1956,13 @@
+ if(OP_UNLIKELY(ret<=0))return OP_FALSE;
+ ssl_session=_stream->ssl_session;
+ if(ssl_session==NULL
+-# if OPENSSL_VERSION_NUMBER<0x10002000L
++# if OPENSSL_VERSION_NUMBER<0x10002000L || defined(LIBRESSL_VERSION_NUMBER)
+ ||!skip_certificate_check
+ # endif
+ ){
+ ret=op_do_ssl_step(_ssl_conn,_fd,SSL_do_handshake);
+ if(OP_UNLIKELY(ret<=0))return OP_FALSE;
+-# if OPENSSL_VERSION_NUMBER<0x10002000L
++# if OPENSSL_VERSION_NUMBER<0x10002000L || defined(LIBRESSL_VERSION_NUMBER)
+ /*OpenSSL before version 1.0.2 does not do automatic hostname verification,
+ despite the fact that we just passed it the hostname above in the call
+ to SSL_set_tlsext_host_name().
+@@ -2314,7 +2314,7 @@
/*Initialize the SSL library if necessary.*/
if(OP_URL_IS_SSL(&_stream->url)&&_stream->ssl_ctx==NULL){
SSL_CTX *ssl_ctx;