aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2019-09-03 16:33:24 +0000
committerprspkt <prspkt@protonmail.com>2019-09-03 21:04:52 +0300
commite92ff72c211bce19ab329378f4090321853cd017 (patch)
tree1a84babbbdde8bd8b8477d53c9262167bbc62a1d
parent315eea94b49031b9dd423401be27921210b76d47 (diff)
community/dvd+rw-tools: add required sysmacros.h header
-rw-r--r--community/dvd+rw-tools/APKBUILD8
-rw-r--r--community/dvd+rw-tools/fix-sysmacros-header.patch10
2 files changed, 13 insertions, 5 deletions
diff --git a/community/dvd+rw-tools/APKBUILD b/community/dvd+rw-tools/APKBUILD
index b2a6afa3db8..a4f2b0461d1 100644
--- a/community/dvd+rw-tools/APKBUILD
+++ b/community/dvd+rw-tools/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
pkgname=dvd+rw-tools
pkgver=7.1
-pkgrel=0
+pkgrel=1
pkgdesc="DVD and Blu-ray burning tools"
url="http://fy.chalmers.se/~appro/linux/DVD+RW/"
arch="all"
@@ -13,6 +13,7 @@ makedepends="$depends_dev m4 linux-headers"
install=""
subpackages="$pkgname-doc"
source="http://fy.chalmers.se/~appro/linux/DVD+RW/tools/${pkgname}-${pkgver}.tar.gz
+ fix-sysmacros-header.patch
transport.hxx.patch"
builddir=$srcdir/${pkgname}-${pkgver}
@@ -30,9 +31,6 @@ package() {
install -m644 growisofs.1 ${pkgdir}/usr/share/man/man1/growisofs.1
}
-md5sums="8acb3c885c87f6838704a0025e435871 dvd+rw-tools-7.1.tar.gz
-fee956907bf81623a8445f1c58e633e4 transport.hxx.patch"
-sha256sums="f8d60f822e914128bcbc5f64fbe3ed131cbff9045dca7e12c5b77b26edde72ca dvd+rw-tools-7.1.tar.gz
-e6b510fe2afe56a10be58c85d23b4d7e65989a3a6ac13be49867383c985b1772 transport.hxx.patch"
sha512sums="938f9ec5597158af275c7bf63002696ba362f6f22a219108c6a1df28792f0485046a7af5ce57e41695aaaa0d69543bd66cbbeb4415df5c0e0a902a3f1d278a31 dvd+rw-tools-7.1.tar.gz
+c3ca41eeac3c50a3c662d358b2e7c5f406b6d946720efad18af5feb26a214c80044c2f529491c51a0b07fb421fcaff45980d038cd7b26d8b8f06a21863c04c3f fix-sysmacros-header.patch
9929fa03fd8a6c9b9ad724d1d0de77a602558bb75691148c7a9562f95b5379149fc39ab66a151c10fbe15e18c75b0ecd2d51f7c0499ced3c2e88a54330c44067 transport.hxx.patch"
diff --git a/community/dvd+rw-tools/fix-sysmacros-header.patch b/community/dvd+rw-tools/fix-sysmacros-header.patch
new file mode 100644
index 00000000000..8ed92e176e2
--- /dev/null
+++ b/community/dvd+rw-tools/fix-sysmacros-header.patch
@@ -0,0 +1,10 @@
+--- a/growisofs.c
++++ b/growisofs.c
+@@ -440,6 +440,7 @@
+ #include <string.h>
+ #include <fcntl.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <sys/stat.h>
+ #include <assert.h>
+ #include "mp.h"