aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex McGrath <amk@amk.ie>2020-10-25 20:34:45 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2020-12-01 23:02:53 +0000
commitec2242fe1ba90e69cf9ea6a013dc92af8ee6b1af (patch)
tree7e18954b6fafa9862acddb984cdfa911c51a09ae
parent2d2d00a0613c2f104f65eebf22b2e5b1fe09f961 (diff)
testing/py3-mpv: new aport
Python interface to the mpv media player https://github.com/jaseg/python-mpv
-rw-r--r--testing/py3-mpv/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/py3-mpv/APKBUILD b/testing/py3-mpv/APKBUILD
new file mode 100644
index 00000000000..0429557814f
--- /dev/null
+++ b/testing/py3-mpv/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Alex McGrath <amk@amk.ie>
+# Maintainer: Alex McGrath <amk@amk.ie>
+pkgname=py3-mpv
+_pkgname=python-mpv
+pkgver=0.5.2
+pkgrel=0
+pkgdesc="Python interface to the mpv media player"
+url="https://github.com/jaseg/python-mpv"
+arch="all !s390x !ppc64le" # Fails with libXss.so.1 (no such package)
+license="MIT"
+depends="python3 mpv-libs"
+makedepends="py3-setuptools"
+options="!check" # tests require unpackaged xvfbwrapper
+source="python-mpv-$pkgver.tar.gz::https://github.com/jaseg/python-mpv/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="cd542b0866d6c75395f1ca00bb6df3981998dd801dcee97b15e080fe66e94270f15daa674f663aa6974dcf6aa425d6e17f8476031badeec035727b2b690816f3 python-mpv-0.5.2.tar.gz"