aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Sinatra <wpsinatra@gmail.com>2020-09-29 08:32:57 -0400
committerLeo <thinkabit.ukim@gmail.com>2020-09-29 16:33:45 +0000
commited34d1376f8ad8205bd215b1893cb981fa78926f (patch)
treea52b9a6a381a7931a63f09d1e0422473aab5744b
parentdf2fa141ddf8727bb88c264e8ab3c0a2b45c162e (diff)
testing/chez-scheme: patch 64bit time on x86
-rw-r--r--testing/chez-scheme/64bit-ti3le-constant.patch12
-rw-r--r--testing/chez-scheme/64bit-ti3le-equates.patch12
-rw-r--r--testing/chez-scheme/APKBUILD12
-rw-r--r--testing/chez-scheme/remove-xlocale.patch1
4 files changed, 33 insertions, 4 deletions
diff --git a/testing/chez-scheme/64bit-ti3le-constant.patch b/testing/chez-scheme/64bit-ti3le-constant.patch
new file mode 100644
index 00000000000..e9d739ec72a
--- /dev/null
+++ b/testing/chez-scheme/64bit-ti3le-constant.patch
@@ -0,0 +1,12 @@
+Alpine ships 64bit time in musl 1.2 on 32bit arches
+--- src/s/ti3le.def
++++ src/s/ti3le.def
+@@ -24,7 +24,7 @@
+ (define-constant size_t-bits 32)
+ (define-constant ptrdiff_t-bits 32)
+ (define-constant wchar-bits 32)
+-(define-constant time-t-bits 32)
++(define-constant time-t-bits 64)
+ (define-constant max-float-alignment 4)
+ (define-constant max-integer-alignment 4)
+ (define-constant asm-arg-reg-max 1)
diff --git a/testing/chez-scheme/64bit-ti3le-equates.patch b/testing/chez-scheme/64bit-ti3le-equates.patch
new file mode 100644
index 00000000000..30dcf91edce
--- /dev/null
+++ b/testing/chez-scheme/64bit-ti3le-equates.patch
@@ -0,0 +1,12 @@
+Change equates.h definition of 0x20 (32 decimal) to 0x40 (64 decimal)
+--- src/boot/ti3le/equates.h
++++ src/boot/ti3le/equates.h
+@@ -611,7 +611,7 @@
+ #define time_duration 0x2
+ #define time_monotonic 0x3
+ #define time_process 0x0
+-#define time_t_bits 0x20
++#define time_t_bits 0x40
+ #define time_thread 0x1
+ #define time_utc 0x4
+ #define timer_interrupt_index 0x2
diff --git a/testing/chez-scheme/APKBUILD b/testing/chez-scheme/APKBUILD
index 23909e8c5ff..0406d00f651 100644
--- a/testing/chez-scheme/APKBUILD
+++ b/testing/chez-scheme/APKBUILD
@@ -2,15 +2,17 @@
# Maintainer: Will Sinatra <wpsinatra@gmail.com>
pkgname=chez-scheme
pkgver=9.5.2
-pkgrel=0
+pkgrel=1
pkgdesc="Cisco R6RS Scheme Compiler"
url="https://github.com/cisco/ChezScheme"
-arch="x86_64" #armv7/aarch64 ports WIP
+arch="x86 x86_64" #armv7/aarch64 ports WIP
license="Apache-2.0"
makedepends="util-linux-dev ncurses-dev libx11-dev"
subpackages="$pkgname-doc"
source="https://github.com/cisco/ChezScheme/releases/download/v$pkgver/csv$pkgver.tar.gz
- remove-xlocale.patch"
+ remove-xlocale.patch
+ 64bit-ti3le-constant.patch
+ 64bit-ti3le-equates.patch"
builddir="$srcdir"/csv$pkgver
options="!check" #No defined checks
@@ -43,4 +45,6 @@ package() {
}
sha512sums="a2dacb8689b49365a33518522df6e8a964f15ec22945c2949c2593612139bf56a755ad269b6c955ac8fed6d6221c6b861f1b0d41a255e2715817b0024c8b9cef csv9.5.2.tar.gz
-29386e6990a4adefcb1bbe7289a27b94dd8d225f2dbcbb1c704ca973263025083a70737a38fa2c815d12036980481b6614d3a332eb05caab2063259896e5b4af remove-xlocale.patch"
+9d324c58cdcf94ccdbf369833d42ab34f7cabb8ee906e54e4f9d98bde45f7cd04e4a040c802407a86d8192a8f8c24f8760f6bba7d6c629dfd428bee80f1b8987 remove-xlocale.patch
+859beb7c4276cefc06b49f685560cc4ef69e1b200d7c52d67c5c24e96e1956ce728b2c72015db92347aef02e803cd2c1e377c836e272619414bd5bf0ce521edb 64bit-ti3le-constant.patch
+1e97c8713ca8d1a18fc4a46b1ccc39f72969c03c9995d0b54c0b2d1710008e5637e6337cc8e809f97bbcbb6c96144f33f9a6cfdd8ebfd2e4dc196e00640a0f08 64bit-ti3le-equates.patch"
diff --git a/testing/chez-scheme/remove-xlocale.patch b/testing/chez-scheme/remove-xlocale.patch
index c04542b3505..21e1e9bd421 100644
--- a/testing/chez-scheme/remove-xlocale.patch
+++ b/testing/chez-scheme/remove-xlocale.patch
@@ -1,3 +1,4 @@
+removing xlocale allows compilation on musl
--- src/c/expeditor.c
+++ src/c/expeditor.c
@@ -546,8 +546,5 @@