aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2021-01-01 17:17:00 +0100
committerJakub Jirutka <jakub@jirutka.cz>2021-01-09 01:41:26 +0100
commitf04683aea1fb60f388600609d4c4fe0c35d2ab55 (patch)
treeb372b0c87cd01acf50c18c8642c3ef525219a7e1
parent1156f025e72fd71e6ca9e8469186f1bb38e2ed53 (diff)
community/emscripten-fastcomp: upgrade to 1.40.1
-rw-r--r--community/emscripten-fastcomp/APKBUILD10
-rw-r--r--community/emscripten-fastcomp/llvm-fix-build-with-musl-libc.patch11
2 files changed, 9 insertions, 12 deletions
diff --git a/community/emscripten-fastcomp/APKBUILD b/community/emscripten-fastcomp/APKBUILD
index 72da8dfb2d5..b024be0e6fd 100644
--- a/community/emscripten-fastcomp/APKBUILD
+++ b/community/emscripten-fastcomp/APKBUILD
@@ -7,8 +7,8 @@
# TODO: Remove unneeded binaries.
pkgname=emscripten-fastcomp
# Keep in sync with package emscripten!
-pkgver=1.39.0
-pkgrel=1
+pkgver=1.40.1
+pkgrel=0
pkgdesc="The Clang + LLVM backend for Emscripten"
url="https://emscripten.org/"
arch="all"
@@ -74,7 +74,7 @@ package() {
rm lib/*.a bin/*-test
}
-sha512sums="574e5b4cf86f16ae455b1f399ecec414f4d791b1b3b49afcd21e967bad62efc572e9f4cd1d2bdce050214ab25e419149bdbfc89cc868ab1019d6ca24c245db63 emscripten-fastcomp-1.39.0.tar.gz
-58422eabd5795d1f9a5806862e7e2ec4489542227765064fa2f7f0930a6b96b59185302ded976189666a4fb452450fbfb37a525b8c7a3d1cc33b7e39b9909dcf emscripten-fastcomp-clang-1.39.0.tar.gz
-f84cd65d7042e89826ba6e8d48c4c302bf4980da369d7f19a55f217e51c00ca8ed178d453df3a3cee76598a7cecb94aed0775a6d24fe73266f82749913fc3e71 llvm-fix-build-with-musl-libc.patch
+sha512sums="569ed4b253db8b8305e93a0e3e3db18e64f7ad55da228b29a632290479c516aa8df6e20b8f695bbdcfdde14ba7be0c4fa27e54c5b1ded3a6cef0d59b3f1cb0d0 emscripten-fastcomp-1.40.1.tar.gz
+f9abae060ebb391d1dd4f3b478cd2214318e333c820a5aca89fcf3bc30bd9903bd56d861c4c60d806ec6539fd340372f686e56d0750ddb06c54802a41b5b4ed7 emscripten-fastcomp-clang-1.40.1.tar.gz
+49e9a3ddf9b1c881c70af4b5c6c99d087733453610f7b2733f91733e92b6097a2f427e496a1374f0f051b8429465de5f1f47d2e08239dca721b59333fc842925 llvm-fix-build-with-musl-libc.patch
b0d692ae595ea72cf6950b7d152c83a301c2f24178ec800a5e9c365961c78067512d0cdedb129fa0e528217a63d861daf6b9e2105d0309f65d3936a779a79144 none-build-type.patch"
diff --git a/community/emscripten-fastcomp/llvm-fix-build-with-musl-libc.patch b/community/emscripten-fastcomp/llvm-fix-build-with-musl-libc.patch
index 6ee91ea44d9..475f04e7130 100644
--- a/community/emscripten-fastcomp/llvm-fix-build-with-musl-libc.patch
+++ b/community/emscripten-fastcomp/llvm-fix-build-with-musl-libc.patch
@@ -14,8 +14,8 @@ diff --git a/include/llvm/Analysis/TargetLibraryInfo.h b/include/llvm/Analysis/T
index 7becdf0..7f14427 100644
--- a/include/llvm/Analysis/TargetLibraryInfo.h
+++ b/include/llvm/Analysis/TargetLibraryInfo.h
-@@ -18,6 +18,26 @@
- #include "llvm/IR/Module.h"
+@@ -19,6 +19,26 @@
+ #include "llvm/IR/PassManager.h"
#include "llvm/Pass.h"
+#undef fopen64
@@ -39,8 +39,5 @@ index 7becdf0..7f14427 100644
+#undef off64_t
+
namespace llvm {
- /// VecDesc - Describes a possible vectorization of a function.
- /// Function 'VectorFnName' is equivalent to 'ScalarFnName' vectorized
---
-2.7.3
-
+ template <typename T> class ArrayRef;
+