aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2020-04-12 10:48:09 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-04-12 09:50:45 +0000
commitf4ea05a852d5573cf874a74d5ad6775dfa45607a (patch)
tree2fe102c731e80865b4680825e1517f11a1d311b1
parentb7d5c9b5723d7ef2489604b68ae5ddeab9fdcf26 (diff)
community/py3-ansicolors: move from testing
Also add check()
-rw-r--r--community/py3-ansicolors/APKBUILD (renamed from testing/py3-ansicolors/APKBUILD)7
-rw-r--r--community/py3-ansicolors/fix-requires.patch (renamed from testing/py3-ansicolors/fix-requires.patch)0
2 files changed, 6 insertions, 1 deletions
diff --git a/testing/py3-ansicolors/APKBUILD b/community/py3-ansicolors/APKBUILD
index 1b1d1eb39d3..4aacd2c2c2e 100644
--- a/testing/py3-ansicolors/APKBUILD
+++ b/community/py3-ansicolors/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-ansicolors
_pkgname=ansicolors
pkgver=1.1.8
-pkgrel=3
+pkgrel=4
pkgdesc="ANSI colors for Python"
url="https://github.com/jonathaneunice/colors"
arch="noarch"
@@ -12,6 +12,7 @@ replaces="py-ansicolors" # for backwards compatibility
provides="py-ansicolors=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
makedepends="py3-setuptools"
+checkdepends="py3-pytest"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip
fix-requires.patch"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -24,5 +25,9 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
+check() {
+ python3 -m pytest
+}
+
sha512sums="5afc4a7a6dc4028ad3db80c0e25e340482295ba41082107287abe7f20f6d4a2d0d17bccf269d7ac71482b7944134487f9238bb2c22c8a2f0bf9ea8288e543378 ansicolors-1.1.8.zip
4473c9a75c5d124e3e587cfb091d8f467bae0cbd23b6ab8295001f5bd91fe5381856b109e2be1a9f1197a5490a2dbd9f83e6e500c9364124b2e66c2826b16ae1 fix-requires.patch"
diff --git a/testing/py3-ansicolors/fix-requires.patch b/community/py3-ansicolors/fix-requires.patch
index 1b5fc8f30c0..1b5fc8f30c0 100644
--- a/testing/py3-ansicolors/fix-requires.patch
+++ b/community/py3-ansicolors/fix-requires.patch