aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-11-21 18:53:42 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-11-21 23:54:49 +0000
commitf666a2d2eeda8013a84e9d0d3bda414bc5ffd607 (patch)
treebf16cbaddcc599d8c5fef49c74463b2bd3090c00
parent5297be6af6251b6616505eb90acd194991def197 (diff)
testing/py3-publicsuffix2: new aport
Python library to deal with publicsuffix data https://github.com/nexB/python-publicsuffix2
-rw-r--r--testing/py3-publicsuffix2/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/py3-publicsuffix2/APKBUILD b/testing/py3-publicsuffix2/APKBUILD
new file mode 100644
index 00000000000..b54f67e33ab
--- /dev/null
+++ b/testing/py3-publicsuffix2/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Michał Polański <michal@polanski.me>
+# Maintainer: Michał Polański <michal@polanski.me>
+pkgname=py3-publicsuffix2
+_pkgname=python-publicsuffix2
+_pkgver=2.2019-12-21
+pkgver=${_pkgver//-}
+pkgrel=0
+pkgdesc="Python library to deal with publicsuffix data"
+url="https://github.com/nexB/python-publicsuffix2"
+license="MIT AND MPL-2.0"
+arch="noarch"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+source="$_pkgname-release-$_pkgver.tar.gz::https://github.com/nexB/python-publicsuffix2/archive/release-$_pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-release-$_pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="$PWD"/build/lib pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
+
+ # remove stray license file; SPDX identifier is sufficient in Alpine
+ rm "$pkgdir"/usr/lib/python3.*/site-packages/publicsuffix2/mpl-2.0.LICENSE
+}
+
+sha512sums="983bdb17b76d10eb73cf69f0ba7590806bf6786ae0c30526593ce1ab97f3b22c967f9acae83b880dd56be41a29eae9cca5726926667eb74013d0d1078433bf05 python-publicsuffix2-release-2.2019-12-21.tar.gz"